Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
2004 ML500 w/ Sport Package
Joined
·
601 Posts
Discussion Starter #1
My ML500 is throwing a CEL since about a day ago. The car has been making some funny smells, almost like when a car is overheating, but not as strong. Its not overheating at all though. I get the wiff of it every once and a while. Then the truck threw a CEL and thats where its at now. When I do start the truck, however, the CEL comes and stays on and where the mileage reads it shows the service wrench and says 1000, but that wouldn't be the reason it would throw a CEL. I've been using regular gas, thats the only faulty thing i can think of. Anyone have any ideas?
 

·
Premium Member
02 ML320 06 ML500
Joined
·
17,043 Posts
The wrench icon with the 1,000 indicates that you will be needing "A service within the next 1,000 miles, but that is not the check engine light.

The odor you are smelling is probably a leak somewhere in the cooling system. Visually inspect it or have the system pressure tested.
 

·
Registered
Black 2005 ML 500
Joined
·
1,662 Posts
Just a couple of weeks ago, I was getting some burnt oil smell, from time to time, inside the cabin.

It turned out to be an oil leak from a gasket and the oil was seeping to the coil inductors down to the cylinder causing it to give the burnt oil smell when it warmed up..

Dealer charges $$$ to fix it. I put the details in one of my past posts.. Though hopefully yours is not this problem...

Regards,

AC
 
1 - 3 of 3 Posts
Top