Mercedes-Benz Forum banner

1 - 9 of 9 Posts
G

·
Discussion Starter #1
I just got finished getting my car serviced and as I hit the CD button on the radio, the radio said 'NO CD CHANGER' The dealer said there is no way they did it and that they do just die out sometimes. Can anyone tell me whether they've experienced this problem. They told me it would cost 660 for a new one. What a joke.<br> <br> Thanks
 
G

·
Discussion Starter #2
Check the connector, it alway loose. Mercedes OE cd changer only $450 (fiber optic) at Autoclass.net
 
G

·
Discussion Starter #3
I've experienced the samething before, but once you restart the engine it'll be back to normal
 
G

·
Discussion Starter #4
i had the exact same post about a month ago...

dunno what was wrong but i fixed it. Here's what happened...ONe day it just said, 'No Changer'. I checked all the connections on the changer and behind the deck....still nothing. It thought I was going to have to buy another from ebay...that's where i got this one for 350 brand new in the box. I would have taken to the dealer becuase since the car is still under warranty they would have been obligated to fix or replace. Since i bought it off of ebay if they would have checked the dealer would have known that I didn't purcahse the changer as an option. So..I took the changer out and took it apart screw by screw. I messed with all the mechanisms and checked all the connections and everything seemed to work fine. I put it all back together and plugged it back into the car. To my surprise it worked fine and has ever since. If you have any questions let me know and I'll try to help anyway i can. I know what it feels like.
 
G

·
Discussion Starter #6
The same thing happend to me yesterday, I took out the cartridge and pulled out all the cd's about half way put it back in and it worked. Maybe it would work for u.
 
G

·
Discussion Starter #7
i tried to take the CD Cartridge out but it lights up and jams. It won't come out. So frustrating.
 
G

·
Discussion Starter #9
Mine does that all the time (2002 CLK430). Sometimes I have to restart the engine a couple of times. Also, the phone isn't recognized. Dealer says they've never heard of that problem before!!! It's irritating considering what we paid. Had it in twice for repair, but it still doesn't work right.
 
1 - 9 of 9 Posts
Top