Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
2000 E320 Sedan
Joined
·
14 Posts
Discussion Starter · #1 ·
I have a 2000 E320 that no longer has a working phone. I have a StarTac that is no longer supported, and am waiting for Mikbox to open for business again so I can buy his adapter. Anyway the old phone is still there but disconnected. Now the cd changer will not work. I tried connecting the phone but still no work. I pulled the phone lever on the steering column but get no response anymore. I just get a "no cd changer" message. Can anyone help me with this?? Thanks
 

·
Registered
2000 E320 Sedan
Joined
·
14 Posts
Discussion Starter · #3 ·
No, the only connector I fool with is the one that goes on the back of the phone. Haven't touched any others yet, so still a mystery. Thanks for the reply.
 

·
W221 & Audio Moderator
2013 S550
Joined
·
11,187 Posts
On occasion a fiber optics connector will work loose on its own; I'd check them anyway (see the phone bulletin for your year and model at Phone Bulletins) for locations; it addresses your CDC also.

A fuse (or internal malfunction of a component) that disables a unit on the bus can also cause multiple problems. Your fuse diagram is usually kept in the tool compartment, often wrapped around a tool.
 

·
Registered
2000 E320 Sedan
Joined
·
14 Posts
Discussion Starter · #5 ·
Thanks for that info Skylaw, I will spend a few hours? today trying what you suggested. I paid for that cd changer and I want to use it!!!
 

·
Registered
Joined
·
33 Posts
I have a 2000 E320 that no longer has a working phone. I have a StarTac that is no longer supported, and am waiting for Mikbox to open for business again so I can buy his adapter. Anyway the old phone is still there but disconnected. Now the cd changer will not work. I tried connecting the phone but still no work. I pulled the phone lever on the steering column but get no response anymore. I just get a "no cd changer" message. Can anyone help me with this?? Thanks
Did the cd changer stop working right after the phone was disconnected? If so then you need to check that area were the disk changer sits. The brain for the phone is in the same area. Possible the disk changer had to be pulled out to get the the brain of the phone, and was never plugged back in.

Good luck
 
1 - 6 of 6 Posts
Top