Mercedes-Benz Forum banner

1 - 9 of 9 Posts

·
Registered
'01 R129 SL500 & '08 W204 C300
Joined
·
94 Posts
Discussion Starter #1
I know guys, I never use it anyway but... I can't bear to have something on the car that was original equip not function. Anyway I put some CD's in the magazine, forgot my ipod at the house so figured I would pick a CD from the changer and be good. CD started playing then after five minutes on the highway I decided to change CD's and didn't know how so I started pushing buttons on the radio key pad. I must of pressed something it didn't like because the music stopped immediately and now I get "No CD CHANGER" message? Please tell me this is a DIY fix and that I don't have to pay a dealer or shop to reprogram something. Pretty crazy MB would have designed the radio in such it could be accidentally programmed to turn off the CD Changer. Any help much appreciated, thanks in advance.

-Ryan
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,000 Posts
Are you using CD or CD-R/W ? The OEM CD-player will not work with CD-R/W.
 

·
Registered
'01 R129 SL500 & '08 W204 C300
Joined
·
94 Posts
Discussion Starter #3
Are you using CD or CD-R/W ? The OEM CD-player will not work with CD-R/W.
Just the standard CD, not a copy. I pressed the number key pad thinking I could go to CD 1, 2, etc.... I think I hit #5 and it zappped the CD Changer off. I hit the CD button to get it to come back on and get "No CD CHANGER" as a message.
 

·
Registered
Departed 1998 SL500 (and the Pano is in Bogota)
Joined
·
11,000 Posts
Try putting a different CD in slot #5, could be just a bad CD.
 

·
Registered
'01 R129 SL500 & '08 W204 C300
Joined
·
94 Posts
Discussion Starter #5
Try putting a different CD in slot #5, could be just a bad CD.
Only problem is now the magazine won't release from the CD changer. The eject light just blinks but the unit won't pop out of the changer.
 

·
Registered
'01 R129 SL500 & '08 W204 C300
Joined
·
94 Posts
Discussion Starter #7
RKH Thanks for your help & response. I think I've got it figured out, the sliding cover on the CD changer has to be completely closed.
 

·
Registered
2002 SL500 Silver Arrow (Sold May 2019 after 11 1/2 years)
Joined
·
198 Posts
My system occasionally won't recognize the CD - tells me there's an error. Easy solution is to eject the CD holder and re-insert. I suspect something gets jiggled now and then, and once I do the above it's all good.
 

·
Registered
99 SL500
Joined
·
122 Posts
Almost bought a new one off ebay but a hail mary repair job at the last minute worked

I encountered the same problem shortly after purchasing mine, and here's how I fixed it.

First, I checked the forums and saw the post about fiber optic plugs failing and taped all mine securely in their sockets - no change. (but glad I did it)

Discovered that the changer mechanism wasn't pulling out the CDs as it queried a magazine after insertion. It would check each slot, but couldn't pull out the disk. I also found that if the eject light blinks when you push the button that means a CD is stuck halfway out of the magazine.

To fix, I had to take the entire changer mechanism out of the metal case, then while rotating the largest gear back and forth, put the proper oil/grease on every moving part and exposed moving surface.

Also, I noticed the catch spring on the magazine was too tight, putting unnecessary stress on the motor to move the trays in and out. I opened and closed all the disc trays on the magazine ~200 times to attempt to weaken the spring. Put it all back together, and 2 months and 2000 miles later, its still working perfectly.
 
1 - 9 of 9 Posts
Top