Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
1993 600 SEC, 2001 G500
Joined
·
119 Posts
Discussion Starter · #1 ·
Hey all,
Looking for some advice or info on why my CD Changer isn't working properly on my 1993 600 SEC with Bose 11 speaker system with trunk mounted 6 disc magazine.
It was working just fine and then one day the CD's would not play.
It appears that everything is trying to engage properly, as I can hear
the normal sounds of machinations, and the digital images on the receiver
appear normal. It seems to act like it is trying to play the CD's but nothing is happening. I checked all wires and everything seems normal. It looks like
the older RCA inputs, so it is more primitive than the newer optical inputs, and when it worked, well, it is some amazing, crisp, clear sounds. I would greatly
appreciate any info from my more technically minded buddies here. Thanks
Cruz90265
 

·
Registered
1993 300SEL (Sold) 2007 X5
Joined
·
7,218 Posts
Cruz90265 said:
Hey all,
Looking for some advice or info on why my CD Changer isn't working properly on my 1993 600 SEC with Bose 11 speaker system with trunk mounted 6 disc magazine.
It was working just fine and then one day the CD's would not play.
It appears that everything is trying to engage properly, as I can hear
the normal sounds of machinations, and the digital images on the receiver
appear normal. It seems to act like it is trying to play the CD's but nothing is happening. I checked all wires and everything seems normal. It looks like
the older RCA inputs, so it is more primitive than the newer optical inputs, and when it worked, well, it is some amazing, crisp, clear sounds. I would greatly
appreciate any info from my more technically minded buddies here. Thanks
Cruz90265
So is it 'playing' as in the tracks show up and there is just no sound? Can you get radio from the head unit. I would go for the amp, I have herd that the Bose ones are prone to failure. If all else is working just as it should with no sound then it may be the amp or some wiring going to the amp or from amp to speakers that has gone bad. The first post of call would be to pull the units and send them for evaluation. If they are all good then you may have to look at getting new speaker wiring.Also do you have a cell in the car? That may be effecting it somehow. I am not an expert on the Bose system the info I have is from that I recently had to get my stereo redone, I went for a single head unit over the CD changer as to get a new cable was going to be 400 bucks. Now I can plug my MP3 player straight into the dash. Fuses may also be at work, is there a fuse for the amp or speraker system? I dunno. But before you rip out your amp wait for some advice from the other smarter members, I am not an expert. Hope this might help you some though and good luck. Let us know how you get on.
 

·
Registered
SEC 600 V12 2dr COUPE (RHD) One of the chosen few.
Joined
·
2,233 Posts
Cruz90265 said:
Hey all,
Looking for some advice or info on why my CD Changer isn't working properly on my 1993 600 SEC with Bose 11 speaker system with trunk mounted 6 disc magazine.
It was working just fine and then one day the CD's would not play.
It appears that everything is trying to engage properly, as I can hear
the normal sounds of machinations, and the digital images on the receiver
appear normal. It seems to act like it is trying to play the CD's but nothing is happening. I checked all wires and everything seems normal. It looks like
the older RCA inputs, so it is more primitive than the newer optical inputs, and when it worked, well, it is some amazing, crisp, clear sounds. I would greatly
appreciate any info from my more technically minded buddies here. Thanks
Cruz90265
I had the same problem..First look to see you have all your disks in the caddy when you remove it. I once tried to load 7!! anyway I took mine out.. dissasembled the case , at the rear there is a worm drive made of white nylon at the rear.. I just manually ran it back to its home position.. worked fine after that...
 

·
Registered
1993 600 SEC, 2001 G500
Joined
·
119 Posts
Discussion Starter · #4 ·
Thanks for the info.
I had recently replaced the magazine as the old one was mysteriously misplaced and it worked fine as it was an OEM part from the dealer. I have re-examined the Changer and the magazine and everything looks perfect. A friend of mine said that there might be moisture on the CD laser glass, but my garage is very dry and somewhat heated. The amp is perfect, radio plays great. I have taken to putting a cassette adapter in the dash and using my portable CD player to play the CD's, which is fine, but there is tape hiss noise when I do that.
I thought about replacing the entire CD changer, but I love the idea of keeping everything stock, and I really think the changer is okay. Any more input would be great. Thanks again,
Cruz90265
 

·
Registered
1993 600 SEC, 2001 G500
Joined
·
119 Posts
Discussion Starter · #6 ·
Thanks Brett,
That sounds like a good idea. And thanks for the link.
Most helpful as always.....
Cruz
 
1 - 6 of 6 Posts
Top