Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
05 E55
Joined
·
99 Posts
Discussion Starter #1
Hi Guys,
my 86 SDL has never been able to keep a fuse since I bought it, so I have been keeping it parked.

I finally got around to taking a look at things. I can replace the fuse, and 5 minutes later, I go to check it, and the fuse is blown, and there is warm air from the vents, and the Compressor is off.

I started by unplugging the Aux water pump, and then I put a new fuse in, AC kicked on when I started the car, came back 5 minutes later, and it was off, fuse was blown.

Thanks in advance!
 

·
Premium Member
1989 560 SEL BLACK ON BLACK
Joined
·
292 Posts
first thing is the fuse the correct one- second is the wire cover worn and the wire touching something that shorts it out- third check the wires going to the AC for the same problem may need to take a rag and clean the wires to see the place where the wire cover is worn thru and causing it to short out
 

·
Registered
E-ZGO 53 HP., 99 E 430 sport, 04 E55 AMG, 2008 Tahoe LTZ Sold Porsche to Brother
Joined
·
1,906 Posts
Mercedes has an upgraded fuse for the CCU. This moves the fuse from the fuse block under hood to an external fuse holder out side the fuse box. What happens over time the original fuse gets hot and the fuse holders and wire attached to them become a point of Resistance and get hot, and the connection deteriorates. The up date is easy to do, all most all Florida cars have this done cause the A/C is on all the time.
 
1 - 4 of 4 Posts
Top