Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm currently trying to install a Nokia cark 126 install my CLK with an Audio 10 and I've found most the info needed to wire everything in except when it comes to the Phone Mute connector. I found that it corresponds to Pin 3 on the Audio 10, but on the ISO block there is no connection going into this pin.

I've tried puting a smallish connector into the ISO but I couldn't get it connected through to the headunit. Does anyone know how are these connections supposed to be made secure?

Please tell me I'm missing something here....

Cheers,
Ian.
 

·
Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,242 Posts
Buy the proper pin at the dealership. They should have them.

Alternately, buy a male...


Buy the proper pin at the dealership. They should have them.

Alternately, buy a male and female ISO connector from a local stereo shop, and wire it straight through except hook up the wires you also need. Then connect one end to the stereo and the other end to the car wiring harness.

-s-
 

·
Registered
SLK 230
Joined
·
61 Posts
Id recommend buying an ISO connector and using piggy back plugs to crimp onto the OEM wire harness. This will allow you to go back to factory within a matter of seconds
 

·
Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,242 Posts
The proper pins work great! You may have gotten the wrong pins for your connector, or you may not have the correct tools to do the crimp, insertion and extraction.

-s-
 
1 - 5 of 5 Posts
Top