Mercedes-Benz Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hello... First thank you to everyone on the forum, your all great help!

So my car wont turn over in the morning.. I put key into start position and it will crank breifly, and stop.. I thank try it again and nothing.. Jump start it and it will crank for a few seconds and stop again.. If I wait it will eventually start up.. After the first start it starts and runs with no issues.

I have a new OEM crank position sensor put in 2 mths ago..

Also I checked battery and alternator, both are good.. Battery is brand new.

Any ideas?
 

·
Registered
Joined
·
373 Posts
Do you have two keys? Try your spare, I had a problem with one of my keys before. It would start the car for two seconds and shut down.
 

·
Registered
Joined
·
3 Posts
I am having the same problem with CLK 270 CDI.

Turn key car starts for like 1 second then cuts out/stalls.

To restart required min 30 seconds on starter with key turned.

After first start of day will start no bother rest of day, bat volt reads 12.7.

Problem started when temperature fell to minus.

Regards
Simon McGreevy
 

·
Registered
08 ml320 cdi,slk 230,01 boxster S,04 carrera911, 99 S320,67 GT350mustang,02G500L,96 s600 w140
Joined
·
1,669 Posts
I am having the same problem with CLK 270 CDI.

Turn key car starts for like 1 second then cuts out/stalls.

To restart required min 30 seconds on starter with key turned.

After first start of day will start no bother rest of day, bat volt reads 12.7.

Problem started when temperature fell to minus.

Regards
Simon McGreevy
12.7 while running? or just the battery?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
one thing i forgot to mention is that if I leave key in on position and heat on for 15 minutes it starts no problem
 

·
Registered
Joined
·
4 Posts
hi all, I have a similar problem on my 2000 s500, last week I changed the front shock, without much trouble, I made several road races and all great, but the park to clean the engine and car body, forget key in the ignition, going about 30 minutes, and the car would not start, not turning the engine and proceeded to check all fuses and finally manually operate the starter relay and it works perfectly, but it stays on since they do not have gas pressure, my question is antiteft system can be reset? would be the case?, could be the neutral switch? and as I could test it, or any other suggestion that a good friend to me, thank you very much for your help
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
turned out it was the starting relay L on passenger side fuse box... I swapped it with secondary air pump and haven't had an issue since
 

·
Registered
Joined
·
4 Posts
Thank you very much brother had done before, even did well with the rest of the relay with no success, I do not think that is the problem of the ignition switch or relay as if it triggers the starter relay manually (by removing the cover plastic), the same look that he turns the key, the engine turns but will not start due to lack of gas pressure, so I tend to a security problem, I disconnected the battery 'for over 24 hr, I used the 2 keys to lock and unlock the doors, remove the 2 fuse alarm, ect with no success, the obd2 scanner shows nothing and the car did not display any error reports, the car only has 66000 miles, but was removed before the solenoid of the shift lever, in other words can move the shift lever without a key in the ignition, my question is, where is located the neutral switch? is easy to change? please if someone knows something about a similar problem would appreciate it greatly, as I see the final destination will be the MB dealer, and we know the price you pay, thanks for your help
 

·
Registered
Joined
·
28 Posts
Discussion Starter #11
Relay didn't work, I was wrong any ideas? Starter is getting no power. If I leave key in and heat on it fires right up
 

·
Registered
2000 and 2003 W220 S500
Joined
·
930 Posts
Do you have a heated garage?
If you do, try leaving the car in there for a few overnights and see if your problem goes away.
If it does go away, it sounds like the EIS is going bad. The EIS has a way of not working very well when it gets cold.
 

·
Registered
Joined
·
4 Posts
Thank you very much for the suggestions everyone, finally solved the problem in a way not very professional but it worked well, try to start the car without success, and leave the mode switch on, I gave manually pressing the starter relay manually and bingo, the engine turned on, turn it off and try again with the normal key without success, I returned it on one more time with the relay, but I showed 3 defects codes (ABS, LIFT, ESP) reviewing the manual could see that after reconnecting the battery, reset the ESP, which is turning the steering well to the 2 extremities completely, bingo and other codes see all disappeared, and I can finally start the car by the normal switch, ie with electronic key, hopefully this will to serve others with the same problem, and wanted someone can also give me a logical explanation of why this happened, thank you one more time
 

·
Registered
W210.265/2001, W220/S500/2000, Porsche 997 C2S/2006, GMC K1500/1992
Joined
·
2,157 Posts
I guess he open the top cover of the relay, it will exposed the contact, which usually activated by the magnetic coil underneath to close the relay, when power was came into the coil. He must manually pushed the contact together so it will crank the engine.
 
1 - 16 of 16 Posts
Top