Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
Please I need help car shook when started car in morning but next day started fine and driving fine I have 2003 MB C230K coupe. Just wondering why it did this?
 

·
Registered
2000 ML430, 2005 C320 4matic
Joined
·
98 Posts
camshaft sensor, very soon when your car gets hot it will die on you, when it gets cold again you will be able to drive, this is your first warning
 

·
Registered
2004 C230 Kompressor Sport Coupe
Joined
·
1,903 Posts
It should have set a pending code ... make sure it's not a single-cylinder misfire, and if it is, time to run some GM Top End cleaner through there. The M271 is known for carboning up the head if you use poor quality gas.
 

·
Registered
Joined
·
31 Posts
this is the problem i have been having for years....i dont disagree with the other guys but this is what i have done to overcome it....its been almost 2 years and i have this problem almost every morning, i start the car and it starts to shake real bad as if the engine is gonna jump out of the hood and start running..haha..now this is what i do to hand cuff it in the hood ..i just hit the gas pedal a little bit and boooom ...problem is gone. It has worked for me for 2 years and i only have to do once every one morning. Now on a serious note i would also llike to know what exactlky the problem is..
 

·
Registered
2003 C230 Kompressor Sports Sedan !998 ML 320
Joined
·
35 Posts
when my 03 kompressor started doing this there were no codes thrown, it took several trips to the stealership before they found a bad exhaust valve on the number 3 clyinder,first starts always were rough when it was warm or the outside temp was above 70 it was fine needless to say this seems to be a fairly common problem on these engines, the fix was a head replacement
 

·
Registered
2003 C230 Kompressor Sports Sedan !998 ML 320
Joined
·
35 Posts
oops sorry first starts when it was cold were rough, rev the motor it would smooth out and if the
motor was warm or outside temp was above 70 it usally started fine
 

·
Registered
03 c230 k
Joined
·
92 Posts
ask dealer

i had same problem in my 2004 c230. turns out some sensor or gasket or something i don't fully remmeber went bad just as my warranty finished up. they fixed for free. it happened again and turned out this time that is was part of a recall from mercedes . so check for all recalls concerning your car. If you need me to i will dig up my paperwork to find out what exactly the replaced warranty wise to help you out.
Please I need help car shook when started car in morning but next day started fine and driving fine I have 2003 MB C230K coupe. Just wondering why it did this?
 
1 - 8 of 8 Posts
Top