Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I own a 1992 500 SEL.

i am having tempreture problem when ever i take my benz on the high way it start to heat up a little bit although i am driving at around 100 to 110 KMH but while driving in the city the temp is normal

Please Advise A.S.A.P.
 

·
Registered
94 s420 98 s420
Joined
·
537 Posts
I think your gonna have to run several inspections on your coolant system to find out whats causing this. It sounds like a clogged radiator, preventing that air to cool off the water at high speeds. make sure the radiator does not have any debri on the outside between the fins( bugs , dirt ect.
Make sure your your not low on coolant with the engine cold (iam sure you checked but just incase), I recently had to add coolant to my system, and I poured coolant right into the top hose, to ensure there were no air pockets. I also squeezed it with the cap off, then capped the tank and released, this helped me prime my system very well. so try to make sure there is no airpockets.
Iam not sure if a bad thermostat would give symptoms as you describe, but if you want to check, you can simply remove it ( make sure you have a spare gasket incase you tear it) and see if your problem still exists. I think if it was your water pump then you would overheat at low speeds as well, probably more low speeds then highway speeds. check your radiator for debri on the outside, make sure air can easly get thru those fins. you can also run pressurized air through( from outside in) at any shop for a few bucks. Finally I would make sure your clutch on the fan is working properly. you should be able to free spin the fan with the engine cold, but it should be locked with the engine hot. allowing no free spinning at all, so it should be basicly locked with the engine hot. ( this could be the very problem as well) I hope this helps!
 

·
Registered
94 s420 98 s420
Joined
·
537 Posts
Now that I think more of your problem, I think its the fan clutch.Your fan clutch should free spin when the engine is cold. However it should lock up when your temerature rises ( engine hot)and spin at the same rate as your engine. If its not locking up and free spinning at high speeds you will get your problem. Still wont hurt to check for debri on the radiator.
 
1 - 3 of 3 Posts
Top