Mercedes-Benz Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
I have a C220 everytime i start up the car the amp is powerd fine, but my sub gets no music, so i played around with the RCA's and then it begins to work. But as soon as i turn off my car and then start it back up,i still have no sound. i have to continue on unpluging the rca's and then plug them back in for the sub to begin to thump again :\. If anybody has any answers to this please help ! <br> Thanks<br>
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
It might be the amplifier is not being turned on.

When you remove and instertthe RCA's, the amp might get a 'jump' in the signal and turn on.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #3
Re: It might be the amplifier is not being turned on.

no, the indication that the amp is powerd is on, the blue led
 

·
Registered
Joined
·
0 Posts
Discussion Starter #4
Re: It might be the amplifier is not being turned on.

What brand and model is your amplifier? If you have something like a portable cd cass or dvd player I would hook it up to the rca inputs on your amplifier and see if it responds in the same way, if it does I would have to say your amp has an internal problem. <br> <br> Scott
 

·
Registered
Joined
·
0 Posts
Discussion Starter #5
Re: It might be the amplifier is not being turned on.

Its a PG Phoneix Gold amp... I heard those where good but i am hearing different since i bought it.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #7
Re: It might be the amplifier is not being turned on.

Sure did, the amp is fine.<br> I need the wiring diagram for a c220... No clue where i could find one or if you guys could hook me up with one. or tell if i have the right cords hood up to the female end of the rca's ?<br> Thanks!<br>
 

·
Registered
Joined
·
0 Posts
Discussion Starter #8
Re: you need the right high level to low level adapter

I would reccomend getting the proper high level adapter. I use either pac or monster cable. I don't know what you are using now but it is not right.<br> <br> Scott
 

·
Registered
Joined
·
0 Posts
Discussion Starter #10
Re: you need the right high level to low level adapter

Well i got one problem fixed, it can take either<br> RCA's or speaker wire. But i have ran into another problem everytime i turn off the stero i get this poping sound in it.. No clue and when i turn it back on it pops again before playing the music.<br> Please HelP!
 

·
Registered
Joined
·
0 Posts
Discussion Starter #11
Re: you need the right high level to low level adapter

How do you have the radio's speaker wire hooked up to the amp? Are you using an adapter to connect it or is it wired directly up to the input of the amp?
 

·
Registered
Joined
·
0 Posts
Discussion Starter #12
Re: Help!

I think i might just save some more money and buy a new Head Unit, so i can just use RCA's. But Im just curious could my alpine cdchanger in the trunk work with a different Head unit, and my security system?<br> <br>
 

·
Registered
Joined
·
0 Posts
Discussion Starter #13
Re: Help!

Try turning down the imput levels on your high low converter. I think it may be too high. Some amps don't have a slow power down and up mode, it sounds like your amp is getting powered up too fast. If you have access to another amp possibly a PPI amp it might make a difference.
 
1 - 14 of 14 Posts
Top