Mercedes-Benz Forum banner

1 - 20 of 20 Posts

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #1
Dear all,

I was unable to start my car at all last night. The smart key does not have the "zip" sound when I plug it in. Nothing was wrong when I drove it in the afternoon yesterday. Really needed your inputs and suggestions on what to do.

Cheers,
Adam
 

·
Registered
My Two Left Feet
Joined
·
3,183 Posts
have you checked your battery for the smart key, my friend with a CLK had the same issue and ended up having to pay for a new one, two days and 300 dollars later.
 

·
W210 Moderator
99 E320
Joined
·
5,044 Posts
i'm thinking that the battery of Smartkey is irrelevant. the valet key is battery-less
yet will still operate the ignition. it does so as the system was designed with
passive IR/inductive interrogator between security system on the car...vs the
circuitry within the key. the batteries serve to power the IR transmitter of the
Smartkey (convenience openings) as well as RF (door locks). but heck, i didn't
design the thing so perhaps Sly's suggestion still has merit. :)
 

·
Premium Member
2001 E320 - Brilliant Silver/Ash: 107,000+
Joined
·
17,193 Posts
Ditto what Raymond said and for the same reason: the valet key will start the car and does not have any batteries. I think I would look in the direction of the ignition switch.
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
I have a similar problem now.

I couldn't open the doors with my keyless go card, so I had AAA come and open the doors for me, which set off the alarm.

I got my smartkey out of my glove box (left there by mistake) and tried to turn off the alram, but nope didn't work.

None of the buttons on my smartkey works, and it wouldn't even turn on the ignition, seems to be locked.

I called Road Side, they thought it was a dead car battery, but turned out fine. The battery in key is new, so can't be the culprit.

I am stranded 300 miles from home and must wait till Monday to have my car towed to the dealer for possible EIS replacement.:bowdown:

Could it be something else? I can try to fix it before Monday. I do have a second set of smartkey, but its 300 miles away and if it is EIS problem it will be useless anyway.:crybaby2:

Any ideas? Thank you,

2003 CL55 AMG
Silver/Black
 

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #6
mjkusa said:
I have a similar problem now.

I couldn't open the doors with my keyless go card, so I had AAA come and open the doors for me, which set off the alarm.

I got my smartkey out of my glove box (left there by mistake) and tried to turn off the alram, but nope didn't work.

None of the buttons on my smartkey works, and it wouldn't even turn on the ignition, seems to be locked.

I called Road Side, they thought it was a dead car battery, but turned out fine. The battery in key is new, so can't be the culprit.

I am stranded 300 miles from home and must wait till Monday to have my car towed to the dealer for possible EIS replacement.:bowdown:

Could it be something else? I can try to fix it before Monday. I do have a second set of smartkey, but its 300 miles away and if it is EIS problem it will be useless anyway.:crybaby2:

Any ideas? Thank you,

2003 CL55 AMG
Silver/Black
Guess there's nothing we can do other than tow it back to the dealer. I'm going to get my quote tommorrow and I expect its going to be expensive. Anyways, good luck man!

Cheers,
Adam
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
Spoke to my friend back in VA who is a MB Technician.
Confirmed, he believes its the EIS also.
Sh*t, I wish I was back in VA.
Must tow car to NY dealer, must pay their full ransom.:surrender:

Good Luck to all MB owners, hope your waranty don't expire b4 your next repair.:eek:
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
Its me again.
Today I went out side and just for the hell of it tried my smartkey remote, and to my surprise, it works. The car is back to normal, all functions are back. I can now start my car again. I am thinking that some how the heavy rain yesturday caused my car to act up. It was sunny today and I think what ever the culprit was got a chance to dry up.

Any way, I am going to drive home to VA and have my friend take a look at my car. Whew, just saved my self a trip to the dealer. ($$$$):thumbsup:

Will keep you posted to what I find out.
 

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #9
mjkusa said:
Spoke to my friend back in VA who is a MB Technician.
Confirmed, he believes its the EIS also.
Sh*t, I wish I was back in VA.
Must tow car to NY dealer, must pay their full ransom.:surrender:

Good Luck to all MB owners, hope your waranty don't expire b4 your next repair.:eek:
My ransom turns out to be around US$2,000, replacing 2 parts:

1) The Electronic Ignition System

2) Steering lock

Cheers,
Adam
 

·
W203, W210 Moderator
E55 ///AMG
Joined
·
6,911 Posts
AdamY said:
My ransom turns out to be around US$2,000, replacing 2 parts:

1) The Electronic Ignition System

2) Steering lock

Cheers,
Adam
Ouch....Do you have extended warranty by any chance?
 

·
Registered
My Two Left Feet
Joined
·
3,183 Posts
I just re-read my battery reply, I actualy should have made my statement different, because it was a run on statement. My friend in a seperate situation was also stuck, but it wasnt his battery, his key just stop working totaly. It good to know you got it fixed.
 

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #12
JOE55 said:
Ouch....Do you have extended warranty by any chance?
I don't have extended warranty, as I just got my car last Oct. from the previous owner. The extended warranty is quite pricey here, costs about US$4,000 per year.

Cheers,
Adam
 

·
W203, W210 Moderator
E55 ///AMG
Joined
·
6,911 Posts
AdamY said:
I don't have extended warranty, as I just got my car last Oct. from the previous owner. The extended warranty is quite pricey here, costs about US$4,000 per year.

Cheers,
Adam
wow $4,000 per year?
 

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #14
JOE55 said:
wow $4,000 per year?
Yes, $4,000 per year. So I'm better off "warranty" myself than pay them $4,000.

Cheers,
Adam
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
Got my car back from my friend (MB Tech), he performed schedule B maintenance and replaced all filters for me. He checked to see the cause of the door/key/alarm problem, but couldn't find conclusive reason for the malfunction. He said nothing shows up on the code and all voltage, or code reading something a magigi works fine. There was no water or corrosion damage to my air or was that vacuum thing so he didn't replace it (costs $700).

Any ways, it happened again last night, my smartkey didn't work, but my keyless go card worked. Its happening at random intervals (it's haunted). Now I carry both.

Got to take it back when I get a chance, to see if anything shows up on the code.

Found a cell phone in my car though... Road side guy's from NY. Overnighted back to him.

Sorry, I was no help at all.:dunno:
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
Ughhh, Sh*t happened again this morning, but this time none of the 4 sets of keys I have is working. Going back to dealer later today. I bet you it will start without any problem, its on and off affair. I think maybe I am causing it, everytime before I try the key I get this wierd feeling that it's not going to work, then it does't work. But if I don't think about it, then it works fine. I am going crazy.
 

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #17
Dear all,

Got my E55 back today. Somehow, the dealer lowered the estimated "ransom" a bit and charged me $200 bucks less. The car is now in good shape again.

Cheers,
Adam
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
mjkusa said:
Ughhh, Sh*t happened again this morning, but this time none of the 4 sets of keys I have is working. Going back to dealer later today. I bet you it will start without any problem, its on and off affair. I think maybe I am causing it, everytime before I try the key I get this wierd feeling that it's not going to work, then it does't work. But if I don't think about it, then it works fine. I am going crazy.
Finally got my car working. It was the EIS that went bad. We replaced the EIS, had to take the whole center console out to get to the EIS. Cost me total of $650. A lot cheaper than at the dealer.:thumbsup:
 

·
Registered
2004 Mercedes S350L, 1999 Mercedes E55 AMG, 1997 Mercedes SLK230, 1992 Mercedes 300SE (sold)
Joined
·
236 Posts
Discussion Starter #19
Do you need to install a software to get the system running? The MB dealer told me that that have to mail the software and code from Germany, so it took a week to do.

Cheers,
Adam
 

·
Registered
2003 CL55 AMG
Joined
·
19 Posts
AdamY said:
Do you need to install a software to get the system running? The MB dealer told me that that have to mail the software and code from Germany, so it took a week to do.

Cheers,
Adam
No, it took them two days to receive the EIS and the Green Key. I don't know of any software, but I was told that the EIS was shipped with the code specifically programmed for my car and that it's not refundable.

Mike
 
1 - 20 of 20 Posts
Top