Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Mb CLK Coupe 270Cdi 2003 avantgarde Vin:WDB2093161F045466
Joined
·
5 Posts
Discussion Starter #1
Hello
I have a serious problem for more than one year.
I can't open my car using remote entry.

MB service in The Netherlands replaced my ignition but that was not the case.They wanted to replace other things when I came with complain:" it worked only for one week."

I've checked batteries-they're good in both keys.The signal is transmitted-checked by camera.
Fuses are ok. Now the tricky part: if the car is standing outside (sunny weather)-opening/closing works perfectly. I know that the remote is connected with the rear window amplifier but I can not open the car using inra-rot as well. Why?ignition replaced with a new one.

When remote entry doesn't work there is no radio frequency found-understandable(the same amplifier). I can't listen to the radio.

I will be very thankfull for any advices where to search for the problem.
I would like to add that connecting the car to "SD" shows no malfunctions.

With Best Regards
Radek
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,377 Posts
Hi Radek - strange fault... Important issue - do you have coupe or cabrio? Antennas & amps are relocated for the cabrio. I am assuming this is a coupe.

Take a look at the overall schematic diagram of the CL system below to understand how the system works.

1. Does the locking system ALWAYS work from the interior switch? Switch N72/1 on the upper control panel is also routed to N73. So if that always works you can eliminate faulty 'actions 2 & 3' on the diagram - and the associated hardware.

Note action 5 - status of door & trunk lid. If these are not OK then the lock/unlock commands will be unsuccessful. Could be an intermittent switch fault there.

2. How about fuel filler cap? Is that affected the same as the door locks?

3. How about the visual feedback from the exterior lights, as defined on the drawing. When the doors do NOT open, do the lights still flash?

4. First impressions here are that you might have an antenna problem. As you know the FM. AM, TV etc antennas are in the rear windscreen heater wiring in the glass. Could there be a fracture (affected by the sun) in the connection from antenna to antenna amplifier? The antenna amp is a problem to access, as it is on the interior of the window glass but under the roof lining. Has anything happened in that area before?

We discussed W209 antenna/amplifier location on this thread recently:http://www.benzworld.org/forums/w209-clk-class/1555043-radio-only-picking-up-local-radio.html

Anyway - something to think about here...:thumbsup:
 

Attachments

·
Registered
Mb CLK Coupe 270Cdi 2003 avantgarde Vin:WDB2093161F045466
Joined
·
5 Posts
Discussion Starter #3
Hello keyhole, thank You for a quick respond.

I have some more answers: It's a coupe.

1.I'm always able to open and close the car from the interior switch.

2.Yes, the remote doesn't open anything, both doors,trunk,fuel filler cap.

3.The lights do not flash when remote do not open the doors.

Probably antenna problem?

Sometimes I'm able to open the car using inra-rot but after 40 times pressing the key button.
The rear window has no metallised foil.

I will check action 5.

If You have any suggestions I would be thankfull,

Best Regards
Radek
 

·
Registered
2004 CLK 320
Joined
·
111 Posts
When I took my car into the dealer, I brought up the fact that I had to be very near my car to open the doors and trunk, almost within a foot or so. When I bought the car I could be many yards away from the car and everything would open quickly.

The service manager asked me if I had put the tint that's on the car now on within that time, and, living in Florida it's necessary, so I told him that I had.

He explained that the reason I have to be so close now is that the antennae or receptor for my key is located in the window, so the tint affected my reception of the key. I haven't read the posts carefully, but is that a possible reason, i.e. have you had the windows tinted?

Just wondering.
 

·
Registered
Mb CLK Coupe 270Cdi 2003 avantgarde Vin:WDB2093161F045466
Joined
·
5 Posts
Discussion Starter #5
My rear window is not tinted, but thanks anyway. I can imagine that tint affected the reception in Your case.
 

·
Registered
Mb CLK Coupe 270Cdi 2003 avantgarde Vin:WDB2093161F045466
Joined
·
5 Posts
Discussion Starter #6
Today I've located the problem, I think so.
I was checking step by step all wires coming from the trunk (rear SAM) and I found one connection (look in attachment) that is responsible for this problem.It is located in the back pillar.
What I mean is: when I was bending this black part my remote start working and the radio started to play again.

This black part is not made of plastic. I can't go inside, it's a sort of tough rubber with the wires inside.
When I was bending it, once I had the signal (remote worked) once I did not.

Anybody knows what that black part is? Can I cut it out and connect the cables together?
Or I am doing only some scintillation and it erases the malfunction in some other part?

What do You think about it?

With Best Regards
Radek
 

Attachments

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,377 Posts
Today I've located the problem, I think so.
Anybody knows what that black part is? Can I cut it out and connect the cables together?
Well done! That 'black part' looks definitely unofficial. MB would never use such rubbish! I would say that a previous owner has interfered with the wiring, and inserted this item. It could be that the cableform was damaged by a rear accident, and had to be extended to reach the rear SAM.

Anyway, it looks like a simple 'through connector' which may have a loose wire inside. You say that you cannot open it, but it has to open somehow unless it is a moulding. It seems to have 2 screws holding it together. Before working on the wires, check with a meter to find if any are live with the ignition off. The red one might be from the prefuse box F32 via f2 @ 200A - so be careful. If in doubt, disconnect your battery negative terminal.

If you really cannot open it, I would destroy it, and replace with another small junction box. Ideally a sealed/waterproof design.
 

·
Registered
2006 C230 sport
Joined
·
1 Posts
Can't unlock my car with the remote

When I took my car into the dealer, I brought up the fact that I had to be very near my car to open the doors and trunk, almost within a foot or so. When I bought the car I could be many yards away from the car and everything would open quickly.

The service manager asked me if I had put the tint that's on the car now on within that time, and, living in Florida it's necessary, so I told him that I had.

He explained that the reason I have to be so close now is that the antennae or receptor for my key is located in the window, so the tint affected my reception of the key. I haven't read the posts carefully, but is that a possible reason, i.e. have you had the windows tinted?
Just wondering.
I got the same problem on my 06 c230 4dr. I can't unlock the car with my remote. This issue started happening 3 month ago after i got my windows tinted. I never thought that the tint was an issue because the problem occurred for a day then it was good for weeks. Today my antena doesn't seem to correspond to any signal coming from the remote. I brought it to MB dealer and they said issue is coming from the antena. They want to replace it but it's $650 for the part + 2.5 hrs of labor @ $125/hr. Too expensive and I believe there is another solution for it.

Can you help me out?? :)
 
1 - 8 of 8 Posts
Top