Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have been trying to locate the yaw rate sensor and lateral acceleration sensor on my 2004 S500 for the last 2 days. No one knows, it's a well kept secret. I am hoping that someone that actually knows for sure where it is will be able to tell me clearly where it is.
I have researched Google, YouTube, another Forum, talked to dealers, and nothing is clear about where it is. I have torn up a substantial amount of my car and nothing... what is frustrating is that I am easily getting exact info on E class, C class, Mls, and W128 but not a thing is mentioned about S500s except vague info that has led me to take apart my trunk, seat, shifter housing, and pull up a lot of carpet. I now am not going to touch this car again until someone with actual experience with this car (2004 S500) tells me clearly where it is, not just where I might try and look.
My ABS light is on, I am getting off and on warnings of presafe is in active and the car is tapping one of my brakes occasionally while driving when I hit a bump. I need to get this fixed.
I have 4 codes under ESP that say there are faults with my rotary speed and lateral acceleration sensors. B24/15. I need to locate test and replace these sensors, so if you are someone who has done this on a 2004 S500 or knows for sure where they are located please tell me. I will greatly appreciate the information.
Thanks in advance, Bruce
 

·
W220 Moderator
Joined
·
6,333 Posts
/\ /\ /\ Yep, +1 exactly where it is ;)

You need SDS to do a special Drive Cycle to calibrate the G Sensors after changing ;)
 
1 - 3 of 3 Posts
Top