Mercedes-Benz Forum banner
1 - 5 of 5 Posts

·
Registered
2003 SLK 230, '06 SLK 280
Joined
·
14 Posts
Discussion Starter · #1 ·
I'm in the Army and am gone TDY a lot...so when I came home after the last trip of a couple of weeks, I started the car and it rattled like the lifters were coming out of the engine...only for a couple of seconds. I called the local dealer's service shop and was told (and later received a fax) that the 2003 Kompressor motor has a NORMAL rattle after a couple days of sitting. They say it's normal on the cam tensioner needing to build back up oil pressure. If this is true, how can I fix it or is it something I will have to live with? Maybe some easy fix?
Thanks,
Bill
 

·
Registered
2003 SLK 230, '06 SLK 280
Joined
·
14 Posts
Discussion Starter · #2 ·
Nobody got a clue? Do I need to post this somewhere else on the forum?
Thanks,
Bill
 

·
Registered
2006 SLK 350
Joined
·
620 Posts
Well, I'm no expert. But I would say anything even approaching sounding "like the lifters were coming out of the engine" would not be normal, even if it went away after awhile. If it is indeed normal, and it is actually a cam or lifter issue, I wouldn't imagine there'd be a fix for it, though.
 

·
Registered
2002 SLK 230 1986 560SL 2008 Honda CRV
Joined
·
3,664 Posts
Hay Bill
My car sat in storage for five months with no issue at start up. If you still have this problem i would look for a good indy and go from there.
 

·
Registered
2003 SLK 230, '06 SLK 280
Joined
·
14 Posts
Discussion Starter · #5 ·
Thanks,
I might be checking into an engine exchange, ,,, depending on if a V6 is reasonable and not too difficult to install. This one's still running fine but.....
Thanks for the info.
Bill
 
1 - 5 of 5 Posts
Top