Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The car downshifts fine but at approx 4000-4200 RPM it stops accelerating and sits there for 2-3 secs at that RPM range and the engine acts as if it is cutting out (just like the rev limiter cut in), then it lunges forward to the red line and shifts. It does this under full pedal down accel and at partial pedal pressure.
It also acts up when the engine is cold, I know that the system delays shifting somewhat when cold, but this car revs to the red line before it shifts when cold. Anyone have any thoughts on both of these situations, thanks.
 

·
Registered
Joined
·
10 Posts
The car downshifts fine but at approx 4000-4200 RPM it stops accelerating and sits there for 2-3 secs at that RPM range and the engines acts as if it is cutting out (just like the rev limiter cut in), then it lunges forward to the red line and shifts. It does this under full pedal down accel and at partial pedal pressure.
It also acts up when the engine is cold, I know that the system delays shifting somewhat when cold, but this car revs to the red line before it shifts when cold. Anyone have any thoughts on both of these situations, thanks.
I don't own a C43, but I've been researching on these forums and I've read that you may need to get the ECU reprogrammed at the dealer and/or because the computer is adaptive in it's control of the transmission, you can get some weird behaviour.
 

·
Registered
1998 C43 AMG
Joined
·
95 Posts
I've never noticed it. Like the user above me stated, it's probably the adaptivity. If you...

I've never noticed it. Like the user above me stated, it's probably the adaptivity. If you drive consistantly for about a week and it still occurs, I would just ask the dealer. Have you owner the car for a while? Has it done this before?
 
1 - 3 of 3 Posts
Top