Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
2002 C320; 17" AMG 5-split-spoke wheels with Michelin PS2 tires
Joined
·
111 Posts
Discussion Starter #1
Driving around town I'm often behind somebody slow, then the lane opens up and I go to pass and I've gotta wait a couple seconds before I wind up past 3000 RPM. What's the deal...stupid manu-matic/tiptronic whatever they call the fake manual override doesn't do any good b/c you have to hit the thing 3 times to get it down to 2nd anyway from D. I keep starting to hate my car, but then I go out and look at it and I'm all better.

Any ideas? Chip mod is pretty expensive, I've already got K&N filters (not a big difference). Exhaust?
 

·
Registered
c230 Kompressor
Joined
·
91 Posts
hyd003 said:
Driving around town I'm often behind somebody slow, then the lane opens up and I go to pass and I've gotta wait a couple seconds before I wind up past 3000 RPM. What's the deal...stupid manu-matic/tiptronic whatever they call the fake manual override doesn't do any good b/c you have to hit the thing 3 times to get it down to 2nd anyway from D. I keep starting to hate my car, but then I go out and look at it and I'm all better.

Any ideas? Chip mod is pretty expensive, I've already got K&N filters (not a big difference). Exhaust?
sprint booster.... and if you want it to be really aggressive, get the manual version instead of auto
 

·
Registered
C230K Sport Sedan
Joined
·
5,368 Posts
Over time the MAF sensor wire gets dirty. Not dirty enough to trigger the CEL but enough to make the car not run quite right, tramission shifts at wrong point, seem like some lost power, etc. Remove the MAF, and then the insert from the MAF and squirt the gold wire at the tip heavily with CRC MAF sensor cleaner, about $6 at most auto supply stores. Also search the forum for MAF and you'll see that many people have cleaned their MAF usually because of a CEL you can clean it anytime. I don't have your specific car but it's usually just after the air filter box on most cars. It's the diameter of the intak tubing an about 5" long and has a wire coming out of the middle.
 

·
Registered
2002 C320; 17" AMG 5-split-spoke wheels with Michelin PS2 tires
Joined
·
111 Posts
Discussion Starter #6
Curacao said:
Hyd003, Do you also have the Winter/Summer (Standard) switch?

Eddie
I have the option, switched to S
 

·
Registered
2017 GLC 300 4Matic fully loaded... but for the heated steering wheel. Stupid previous owner! 😠
Joined
·
1,142 Posts
Instead of pulling the shifter to the left two or three times, try pulling and holding it to the left for one second. The transmission usually shifts into the right gear for optimal acceleration/deceleration.
 

·
Registered
2002 Silver C320, 19x8.5 19x9 , Eibach Pro, K&N, Alpine CD, JL, Zapco
Joined
·
88 Posts
I have a 2002 c320 with 19's and it accelerates fine. If you hold the shifter it down shifts to the lowest gear possible for the rpms. Also I have k&N filters and have had to clean the sensor because of dirt collecting on the extra oil. Then my engine ran fine again.
 

·
Registered
2002 C320; 17" AMG 5-split-spoke wheels with Michelin PS2 tires
Joined
·
111 Posts
Discussion Starter #9
midnight kompressor said:
sprint booster.... and if you want it to be really aggressive, get the manual version instead of auto
Are you saying to get the manual version and put it on my automatic car?
 

·
Registered
2002 C320; 17" AMG 5-split-spoke wheels with Michelin PS2 tires
Joined
·
111 Posts
Discussion Starter #10
hyd003 said:
Driving around town I'm often behind somebody slow, then the lane opens up and I go to pass and I've gotta wait a couple seconds before I wind up past 3000 RPM. What's the deal...stupid manu-matic/tiptronic whatever they call the fake manual override doesn't do any good b/c you have to hit the thing 3 times to get it down to 2nd anyway from D. I keep starting to hate my car, but then I go out and look at it and I'm all better.

Any ideas? Chip mod is pretty expensive, I've already got K&N filters (not a big difference). Exhaust?
UPDATE: I did the "reset" that was described on the MBworld forum. If you're not familiar, it's the way to reset the "learning" on the automatic transmission. Made a difference.

1 - turn ignition key to ON (not start)
2 - hold accelerator pedal all the way down and hold for 5 seconds
3 - turn key to off (pedal still down)
4 - let go of pedal
5 - wait at least 2 minutes before starting again.

I will clean the MAF sensor as well. This summer I will give the sprint booster and an aluminum pulley a try.
 

·
Registered
c230 Kompressor
Joined
·
91 Posts
hyd003 said:
Are you saying to get the manual version and put it on my automatic car?
yeah... some people have done it, but its not for everyone. people say its "too agressive" and others like it. i have the manual version on my manual c230 and i love it... i can't i magine how it would feel on an automatic... but i've heard that people do it
 

·
Registered
Joined
·
3 Posts
Sprint Booster Works!

I have c320 sports model, and the gas pedal is Fly by Wire, which is WHY THE LAG and sluggish. Went on e-bay and found sprint booster for about $285. Simply remove the gas pedal bolt, and install the connector to this black box inline and re-install pedal Takes about 5 minutes.
NO JOKE! you can Really Notice the Difference. Like a Different Car. To take off, no more than 1/4" makes it go fast so you have to RELEARN DRIVING AGAIN, but its also safe in aParking lot somehow. You only put the pressure of your foot and that is all you need. Before It was like 2-3 inches instead its 1/2" to 1" for same with quicker response. I keep saying to myself, will take it out to see what it was like BEFORE. no kidding, i want to take it out to notice the difference, but then DONT, because I dont want it the way it was even to check it out, cause its so Great the way it is. Its been the best mod for the car I have done, cause it has the QuickPower when you need it for passing and taking off. Its funny to see others at the light try to keep up, NO WAY, I always Win. Its alot $285 to 300 bucks for it tho, but it really does work. Have had it for about 1 year now, and still have not removed it to see the way it was when it was sluggish. Dont Want that feeling again. Already Know its Big Impvements. This same things WORKS ON MOST ALL MERCEDES TOO.
the ones with the Fly by wire setup. Not Mechanical Cable.
 

·
Registered
2004 C230 Kompressor Sport Coupe
Joined
·
1,903 Posts
Holy old thread, Batman!

The Sprint Booster has been gone over plenty here. It's exactly (exactly!) the same as pressing the pedal further. If you like it, cool, but that's all it does.
 
1 - 13 of 13 Posts
Top