Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter #1
We have a Mercedes C240...got it about a year ago..started making a creeking noise when ever you pull into a driveway or go over a speed bumb. Usually happens when you hit the bump with one wheel first. You don't have to be going very fast for the noise to occur. We have taken it to the dealer atleast 4 times...recently the tech even heard the noise...can't find the problem...anyone out there have any similar experience??<br>
 

·
Registered
Joined
·
0 Posts
Discussion Starter #2
I've noticed that happening in my C240, but in mine I thought it was because I put aftermarket springs on. It's getting really bad and to the point where I can hear it over the music. I was going to get it checked out on my next trip to the dealership.<br> <br>
 

·
Registered
Joined
·
0 Posts
Discussion Starter #4
We have a similar problem here in Malaysia. From what I heard, DCAG first replaced the rebound stop on top of the strut. This could be seen when you open the hood. If there's more than 1mm of clearance to the top of the top strut mount, then it should be the new part.<br>
<br>
Next they found that the bearing for the shock strut (looks like a cup when you remove it)had some problems. The new part will be available soon.<br>
<br>
Just my 2 cents.
 

·
Registered
Joined
·
0 Posts
Discussion Starter #5
Creeking noise on 2001 C320 also....

Hello,<br> I was just at my MB dealer to check on the creeking noise. Car has 15k miles. The tech told me that there is apparently a problem with the 'C' series suspension. They are going to replace all 4 shocks. Also, I hear a humm when I decelate, specially noticeable on asphalt. Anyone notice this? <br> <br> Regards,<br> Orlie
 

·
Registered
Joined
·
0 Posts
Discussion Starter #6
C240 Creeking noise from Back Driver Side

I dont have the squeeking noise in front but in the back on the drivers side. it seems to make the noise when i sit in the car or move it around after the car has been driven when the ignition is off. my car is about 3 months old...i put aftermarket springs (h & r) and 18 amg rims on the car but it had the squeeking prior to the installment of the parts. does anyone know if these parts void the factory warantee in the US? thanks.
 
1 - 6 of 6 Posts
Top