Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2003 Mercedes Benz c230 coupe with automatic and evolution package
Joined
·
65 Posts
Discussion Starter #1
Hi guys,

I have a 2003 c230k coupe. it starts and drives fine, then you park, turn off engine and immediately try to restart and won't start. lights come on, fan comes on, but starter wont click or engine won't turn over...wait about 20 minutes and then the car starts again...

Any help would be most appreciated
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,045 Posts
I'd start by checking the vehicle's battery voltage. You should see 12.6v at rest, no less than 11v when trying to crank, and 14v at idle. If all of that is good, then check the starter relay:


If that's good, then it may be the starter itself. Sometimes the braided wire that runs from the solenoid to the starter motor deteriorates from environmental conditions. It may be so thin that when the engine is hot, it won't conduct enough current.

Another possibility is a bad CPS. Try pouring cold water on it and if that works, replace it.
 

·
Registered
2003 Mercedes Benz c230 coupe with automatic and evolution package
Joined
·
65 Posts
Discussion Starter #3 (Edited)
Thanks Rudney :) what ive noticed is that the radio can be turned on whether the key is in or not, is that normal? Also, I have never changed the battery in the key fob. because ive noticed I can't open the door locks so battery must be dead...could the key fob have something to do with this? thanks
 

·
Coupe/Convertible Forums Moderator
CURRENT: 2011 SL550, 2011 C300 FORMER: ML350, CLK550 Cabriolet, C240, ML320, 300TD
Joined
·
19,045 Posts
Being able to switch on the radio with the ignition off is normal behavior. It's a "feature". As for the battery in the SmartKey fob, it is only used to power it for RCL (remote central locking). The DAS (drive authorization system) which recognizes the key in the ignition and enables start is unrelated. The fob has a small coil in it that is inductively powered by a coil in the ignition switch. The key will still function for DAS regardless of whether the battery is in the fob or not. RCL does require the battery in the fob for it to function and lock/unlock the doors.
 

·
Registered
2001, w203, C220 105kw
Joined
·
65 Posts
Hi,
i had a similar case.
When attempting cold start engine was turning but wouldn't start the car, after multiple attempts it would eventually start. Later with a warm engine and with little hesitation, the car would be running. In the end, the diagnostic tool showed that the camshaft sensor was malfunctioning. After replacing that sensor everything was back to normal.
 
1 - 5 of 5 Posts
Top