Mercedes-Benz Forum banner
1 - 20 of 35 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
hi. i have a mercedes c180 w202,i keep her in good condition for her age,changing replacing parts slowly as and when i can afford to ,as i would like to keep her running for aslong as possible. my recent problem is when i am driving she has started to jus cut out " engine cuts off ??? and i have to put my hazards on ,pull over ,restart then drive off again ?? im thinking this is either my fuel filter and fuel pump ???? am replacing at weekend ,but as will be nearly £100 in parts does anyone have any othe suggestions as to the possible cause ???????before i spend money on a the wrong problem, any help would be great :)
 

·
Registered
Joined
·
880 Posts
More likely electrical.

Try this, when it cuts out just turn the key off and right back on. See if the engine starts up again. You can do this without stopping the car.

Practice by doing this when it hasn't cut out, this way you won't be nervous when it happens, and you'll know what to expect.

Don't replace the fuel pump if you don't have to.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 · (Edited)
mercedes c180 w202 cutting out while driving.....

thanks for the replys :) well i know i could restart the car whilst still in motion ,but would this not ruin the gear box somehow ??? it has done it whilst i been on motorway ?? i jus put my hazards on and get over quick as ...shes done 210k now but i have renew'd battery little while back ,water pump ,all the abs system ,exhaust from cat to backbox ,.......what is a k40 relay ??i have a manual il have a look once i done this ... i am thinking its lacking a good spark or something <maybe change the plugs ,leads n coil packs,but im sure i only done them last year???? hopefully this relay might be an easy thing to replace aswell jus to eliminate possiblities......a mercedes c180 w202 1997 saloon

also when restarting the engine is struggling to hold her self and is cutting out again ,but have noticed this more today as when driving home it cut out 3 times in a row then started and i got home ok , but some days no problems at all ????
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
Well
I have re soldered the k40 relay , but car still cutting out , bit worse now though. Have been told to change the crank shaft poss sensor but can anyone tell which It is with out removing old one, on my model twin pin or single, only £ 34, so worth changing jus to see if that's the problem !!!
 

·
Registered
1991 300CE RIP, 1999 C280, 2000 C280, 2000 C230K RIP, 2011 C300
Joined
·
712 Posts
My acted a bit different when the crank PS turned out to be faulty. It started as a random no start. After the car started, it ran normally until the next arbitrary non-start. This progressed to random shut off while driving. Car would sit 5-10 minutes, then start and run normally.

You may just have to disconnect and take a look. Not hard, just awkward and you need small hands.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
mercedes c180 w202 engine cutting out when driving ???

today i have changed the fuel filter and have located the crankshaft poss sensor, i have taken this out given a bit of clean up with wire wool. but no change ,still cutting out ??? something else funny i have noticed ,is that when i push the heated rear windscreen button it cuts the engine out ??? i have a new crankshaft poss sensor comin monday ,so il replace that n go from there ... if thats not the fault ,any other ideas as to what else could be causing this ??? ecu maybe ???

thank you for your replies so far ,has been very helpfull
 

·
Registered
2009 C200k Avantguard.
Joined
·
108 Posts
With the crank position sensor fails it usually happens after the car has heated up. Let it cool and it starts up again.

If this isn't it, then it could be a faulty coil(s), or wiring harness (especially on pre-97 models).
 

·
Registered
1997 C200
Joined
·
9 Posts
mercedes c180 w202 engine cutting out when driving ???

Did you finally get a solution for the issue you had raised?
Am suffering with a similar issue with my W202 1997 model which keeps cutting out thou after complete stop its able to start again.....very annoying and other motorists think you don't have gas!!!!!!:mad:
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #12 ·
hi..yes mine is no longer cutting out when driving ,this i resolved by changing the crank shaft possition sensor. and i also went to the battery and made sure all the terminals were ok ,but they looked old so i cut them back to nice wire and re wired them, which im sure has also helped.... sensor was only £40 and really easy to change as i did myself . jus reaching down the back of the engine bay and theres the sensor is there ,allen key to undo swap for new n back together . .. have u looked ,changed anything yet to try resolve your problem ?? but yeah mine would jus die while going along n i could pull over restart and go off again but it did get worse and has not happened since changing the sensor ..
 

·
Registered
Joined
·
31 Posts
Nesh

I had a similar issue about a year ago when the car had about 190K miles on it with the original pump. The problem was the fuel pump. The engine cut out while driving. I was able to restart after I came to a stop and got the car back home. I did not continue driving the next day as a I root caused the issue to the fuel pump (original Bosch was $215). After I replaced it, I was back to normal. I took apart the old fuel pump after the repair and the commutator brushes were completely worn out. Outside of that the pump was mechanically in good shape.

You can also check the fuel pump relay as another option.
 

·
Registered
1997 C200
Joined
·
9 Posts
Thanks guys, I have had to take my car for a full diagnosis and it was noted that the oxygen sensors were off and after sand-washing both front and rear the error cleared. However, am still suffering from the issue though now am being informed that the issue could be on k40 relay. Interestingly the diagnostic report didn't indicate any fault stored/present this is purely based on the experience(know how) of my mechanic.

Initially i suspected fuel pump relay but the diagnostic report gave a clean bill of health.
 

·
Registered
Joined
·
1 Posts
my issue

I have a 1999/2000 C180 mercedes benz that i love so much. The problem i have with it is that anytime am in traffic it trips off and i have to start again and continue.
But when am on the high way it can run for as long as i want. I also noticed that when i drive into a flooded area or it rains heavily it never trips off. Please any ideas? i have changed fuel pump, coils and spark plugs. i also changed fuel filter and even serviced it with full synthetic engine oil and it still does this.
Someone please help me as i love this car so much
 

·
Registered
1998 C240 Elegance (W202) and 1996 C220 Classic (W202)
Joined
·
25 Posts
Check Wiring Harness

Hi,

I had this exact problem a few years ago on my C220.
The problem was 2-fold:

1. The insulation on the wiring harness was cracked (common problem on these models) and needed to be replaced. A short-circuit during driving will cause the engine to cut out as a safety measure. Car is fine to restart again (until the exposed wire brushes against the engine again).

2. The mechanic also found that one of the clips that connect the ECU to the wiring harness was broken, so when driving it would would become loose and the connection would be intermittent. This also would cause the engine to cut-out.
 

·
Registered
1991 300CE RIP, 1999 C280, 2000 C280, 2000 C230K RIP, 2011 C300
Joined
·
712 Posts
The harness issue was particularly a 1995-1996 issue.

Sounds like a crankshaft position sensor issue which is relatively common. Mine seemed to be temperature related, where if I just waited a little bit for the car to cool then the car would restart and run normal until the next event. That could be why you don't have the problem when the weather is cooler and wet.
 

·
Registered
Joined
·
1 Posts
mercedes c180 w202 engine cutting out when driving ???

Did you finally get a solution for the issue you had raised?
Am suffering with a similar issue with my W202 1997 model which keeps cutting out thou after complete stop its able to start again.....very annoying and other motorists think you don't have gas!!!!!!:mad:
[I have a similar experience, my 1996 Benz C 180 engine cut off when it has moved for like 30mins .l discovered that this happens when fuel pump is hot and it seems my fuel pump gets hot easily.l have changed my car fuel pump 2 times, yet the problem persists. A mechanic said it may be a dirty gas tank internal filter that reduce fuel supply
 

·
Registered
Joined
·
1 Posts
hi, i hav mercedec benz C200(w202-1997). i have some fuel issue from a week. car stop during driving, fuel is enough a 1/4 tank. i think fuel gauge may incorrect, i put some petrol in it, it start. after some drive engine stoped again. and again i put some petrol in tank, then engine start normal again. this repeat several time, now fuel is up to hafl tank. whats the problem
 
1 - 20 of 35 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top