Mercedes-Benz Forum banner

21 - 23 of 23 Posts

·
Coupe/Convertible Forums Moderator
Joined
·
18,686 Posts
Probably a CPS failure, but P0720 is unrelated - that's a problem in the TCU which would not cause the engine to stall.
 

·
Registered
Joined
·
5,408 Posts
After the stall did you mange to start the engine immediately ? If so, it is less likely a CPS issue. Usually you need to wait for the engine to cool off first for it to re-start with a flaky CPS..

The P0720 code is a code generated by the TCU complaining about communications issues with the Traction Control (N47) module regarding the implausible Vehicle speed sensor info. To find out if this is the TCU error or the N47 error, both modules need to be scanned with an MB Star or equivalent for codes.

A 110 degrees F temperature.. Probably the a/c is running at full capacity, with the cooling fan at maximum. you stop. The engine stalls. Are you sure your battery is good? When you have a lot of power consumers, and the alternator cannot supply demand (low rpm during stopped traffic), you start discharge from the battery. If the battery is weak the voltage drops, and the electronic modules start dropping too.
 

·
Registered
Joined
·
69 Posts
After the stall did you mange to start the engine immediately ? If so, it is less likely a CPS issue. Usually you need to wait for the engine to cool off first for it to re-start with a flaky CPS..

The P0720 code is a code generated by the TCU complaining about communications issues with the Traction Control (N47) module regarding the implausible Vehicle speed sensor info. To find out if this is the TCU error or the N47 error, both modules need to be scanned with an MB Star or equivalent for codes.

A 110 degrees F temperature.. Probably the a/c is running at full capacity, with the cooling fan at maximum. you stop. The engine stalls. Are you sure your battery is good? When you have a lot of power consumers, and the alternator cannot supply demand (low rpm during stopped traffic), you start discharge from the battery. If the battery is weak the voltage drops, and the electronic modules start dropping too.
my son was driving and he said the engine did not shut down, just sputtered and he lost the power brakes momentarily, which was a bit scary on a busy road.

Is it possible i messed with the N47 module while replacing the brake pads two days earlier?

The battery was replaced last year with a battery from walmart. May be that was a mistake, This morning i checked the voltage and it was 12.4 V (engine off). May be this battery did not like the heat.

I will be getting the icarsoft scanner tomorrow hopefully i can scan some systems.

Thanks for the replies guys.
 
21 - 23 of 23 Posts
About this Discussion
22 Replies
6 Participants
silver7
Mercedes-Benz Forum
BenzWorld.org forum is one of the largest Mercedes-Benz owner websites offering the most comprehensive collection of Mercedes-Benz information anywhere in the world. The site includes MB Forums, News, Galleries, Publications, Classifieds, Events and much more!
Full Forum Listing
Top