Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
2008 E350, 2001 E320 Wagon; 2000 S430
Joined
·
30 Posts
Discussion Starter · #1 ·
I run the full diagnostic on my 2000 S430 (155000 Mls). During the diagnostic the ignition is on and I hear the buzzing vibrating noise from the air intake side. Using the stethoscope, I could pinpoint to the airflow sensor/air intake area. No error code showing for the engine diagnostic. I’m just cautious and try to prevent any road side breakdown. Since the air intake regulation is with "fly by wire" is there an electric motor to adjust the air intake valve?
 

·
Registered
1995 E320 (totalled) 91 420SEL W126 (retired) 2002 S500 W220(retired); 2008 C300 Sport W204
Joined
·
662 Posts
Have you checked your air filter assembly lately? There may be debris in the intake area of the airbox and filter. Take out the torx screws and clean out the inside. With no check engine light I would look for stuff like that first.
It could also not be seated properly this could cause a "buzzing" noise.
I think the airflow is actuated by vacuum that is driven electrically. Maybe other users can chime in on this one too. I know I had buzzing noises before coming from the air intake area on the S500 and it was a piece of cellophane stuck in the air intake that was acting like a Kazoo!
 

·
Registered
2008 E350, 2001 E320 Wagon; 2000 S430
Joined
·
30 Posts
Discussion Starter · #3 ·
Thanks, but the airfilter assembly is removed for the diagnostic.
 

·
Registered
1995 E320 (totalled) 91 420SEL W126 (retired) 2002 S500 W220(retired); 2008 C300 Sport W204
Joined
·
662 Posts
Does the buzz go away when someone pushes the accelerator?
 

·
Registered
2008 E350, 2001 E320 Wagon; 2000 S430
Joined
·
30 Posts
Discussion Starter · #5 ·
Does the buzz go away when someone pushes the accelerator?
Pushing the accelerator does change the buzz-frequency but it goes back to the original buzz when the accelerator not pushed. I think I will remove the whole assembly and take a closer look, whit all the connection and ignition on.
 

·
Registered
2001 SL500
Joined
·
494 Posts
I run the full diagnostic on my 2000 S430 (155000 Mls). During the diagnostic the ignition is on and I hear the buzzing vibrating noise from the air intake side. Using the stethoscope, I could pinpoint to the airflow sensor/air intake area. No error code showing for the engine diagnostic. I’m just cautious and try to prevent any road side breakdown. Since the air intake regulation is with "fly by wire" is there an electric motor to adjust the air intake valve?
PMat, did you ever get this solved?
I have the same noise coming from the same spot on my 2001 SL500 (M113) when checking codes with the ignition key in position 3.
Exactly what is buzzing?
Is it doing any harm?
Is there a way to turn it off without interrupting the diagnosis procedure?
Any help with this would be much appreciated! :bowdown:
 
1 - 6 of 6 Posts
Top