Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #1
With the engine running, when I open the door and put my car into reverse, the buzzer used to warn me about the open door. But now it stopped buzzing or did it intermittently, like a crackling noise. When I preglow the engine, it buzzes LOUD though, so I know the microswitch (buzzer) is good.

Reverse lights are working, both sides. But buzzer does not turn on when in reverse AND the driver door is open.

What do I need to look for? Could this be related to a loose shifter bushing or two? I have yet to replace those...TIA
 

·
Registered
1984 300D Turbo
Joined
·
130 Posts
Hey Karugs,

Mine does not buzz at all when I put it in reverse with door open [:(] Does your buzz to tell you that the glow plugs are ready? Mines doesn't do that either. The only time mine will buzz is if I leave the lights on or when I leave the key in the ignition.

I don't think a shifter bushing could cause the problem, and let me tell you if yours are not broken or missing be very happy! WOW! what a job that was! [xx(]

Mike
 

·
Premium Member
W-1-2-3 Go!
Joined
·
16,161 Posts
Discussion Starter #3
Hi Mike, well I tried it today and before putting the shifter to R I let it sit on the notch between R and P. Then snapped it to R. Lo and behold, it worked! Maybe it was just loose? I bet it's just a loose contact.

Yes, mine buzzes when in the pre-glow part. But it goes away after a couple of seconds. I think the buzzing is related to the seatbelt. When I put on my seatbelt before I put the key in, no sound. When I leave my lights on it does buzz too. So I suspect the reverse switch thingie, I'll look more into it.

Too bad, my bushings are somewhat shot. I can sometimes hear/feel a small rattle of the shifter. Nonetheless, it's another project to do. [:p] How is your Ivory car doing? Hope all is well!
 
1 - 3 of 3 Posts
Top