Mercedes-Benz Forum banner

1 - 4 of 4 Posts

·
Registered
1995 C280 & 1996 C280
Joined
·
15 Posts
Discussion Starter #1
1995 C-280 105k miles
It was taking the engine about 10 miles to get up to 80°C on the temp gauge. Then we had a day of 32°C and it got up to 100°C on the gauge.
I figured a stuck thermostat so I bought a new one and new coolant. When I removed the housing the thermostat was broken. One of the flat bars that goes to the top of the valve was broken. No corrosion, nice and clean. Says "Wahler Made in Germany" on top and 87° on bottom so it could possibly be the original. Never saw or heard of a broken one before.
After a good flush, new thermostat and coolant, temp gauge rides on about 90° now. Off the freeway will get up to ~100 but no higher. I think the cooling system is working correctly now.
George
1995 C-280
1996 C-280
 

·
Registered
1998 C280 Sport 2002 C320 2007 C230 Sport
Joined
·
26 Posts
I recently acquired a 95 C280 and it runs around 105 to 110 when in traffic and concerns me, although I live in arizona with high heat! My gauge also takes a while to come up, usally about 10 minutes or so and I'm wondering if this is a thermostat problem.
 

·
Registered
2001 CLK55 AMG, 2002 C32 AMG
Joined
·
1,637 Posts
the gauge taking a while to come up could be a sticky needle problem. when it does come up, does it suddenly jump to the value. i guess it could also be a sticky thermostat. if your running that hot, it sounds like you probably need a new thermostat. they arent too bad of a price especially if it fixes your problem :)
 

·
Registered
1998 C280 Sport 2002 C320 2007 C230 Sport
Joined
·
26 Posts
the gauge taking a while to come up could be a sticky needle problem. when it does come up, does it suddenly jump to the value. i guess it could also be a sticky thermostat. if your running that hot, it sounds like you probably need a new thermostat. they arent too bad of a price especially if it fixes your problem :)
Went by the MB dealer and got a MB thermostat which solved the problem, running nicely between 85 to 90 C. The thermostat i pulled out looked fine but must have been sticking, it was not a MB labeled piece. Thanks for the help.
 
1 - 4 of 4 Posts
Top