Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2005 W215 CL500
Joined
·
3,546 Posts
Discussion Starter #1
Discovered two broken springs at the front!! Was hitting the ground after road humps and rough roads in the West of Ireland . Had the car up on a lift on Tuesday and discovered I also had the optional Steel sump guard, thank goodness. Anyone else have one of those?
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
You been driving through the Giants' Causeway or something? I've read a couple of posts about a broken spring, but the first time I've heard of both breaking. :eek:

Glad no one got hurt, you or the car.

I don't have the off-road package on mine, though. :)

Take care and enjoy the ride,
Greg
 

·
Registered
2005 W215 CL500
Joined
·
3,546 Posts
Discussion Starter #3
No you can't get to the Giant's Causeway by car, however there is a small bus that does the run from the car park for the elderly and/or infirm ( I'm neither).

No I was in Donegal last Saturday. The springs may have been broken for some time. About three inches from the end at the bottom in each case. We like Rallying in Ireland and so the steel sump guard is not unusual, least ways not on Subarus and Mitsubishis...

Anyway here's a photo from Donegal...
 

Attachments

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
Hey, CS. Nice juxtaposition of the car and the wreck in the background.

FWIW, I know you can't drive to (or on, lol) the Giants' Causeway, I was just kidding around because I never heard of anyone breaking both front springs. Weird.
 

·
Registered
2005 W215 CL500
Joined
·
3,546 Posts
Discussion Starter #5
Hi Greg I know you were joking:)

Anyway the spring thing is more common than you might think. The guy in the following had the problem, and he was the one who discovered mine when the car was up on his lift:

Replacing Front Springs on a 210 - MBClub UK Forums
 
1 - 5 of 5 Posts
Top