Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
1994 E320
Joined
·
1,730 Posts
Discussion Starter #1
Hi people,

Looks like my odo broke just after I passed the 111111km mark [:D].
The speedo still works, but neither the odo nor the trip counter work. Upon a closer look, I saw that the roller assembly seems to have been nocked off its seat - it seems to be "sunken in" on one side with the digits only half-visible.
Is it possible to take the speedometer assembly apart and get it fixed? Is it worth it, or should I just get a replacement? I don't want to lose track of the original mileage. Any suggestions are appreciated.

TIA,
Shady
 

·
Registered
SL320, 300e, 450SL
Joined
·
1,044 Posts
Shady, here in my home town, there is a place that only does odometers and fixes these kind of issues. A job like that could involve 2 to 6 hours after you take into account dismantling the dashboard. They bill out at some $60-80/hr USD. Ive also seen complete used odometers fully operational that you could buy used and if you fully document the changes from your shop, it wouldnt be much of an issue down the road. I would want my stock unit fixed.
BTW Shady...Nice Camel[:D][:0][:D][:0][:D][:0][:D]
 

·
Registered
Joined
·
61 Posts
Hey Shady,

The solution is to buy a used one. It's the cheapest solution. You can check locally where you live or http://motors.listings.ebay.de/Instrumente_Mercedes_W0QQfclZ3QQfromZR11QQsacatZ99207QQsocmdZListingItemList

The only reason that I know that a odometer fails the way you are describing "...that the roller assembly seems to have been knocked off its seat - it seems to be "sunken in" on one side with the digits only half-visible." is because it was tampered with. At 111km it's too soon for it to sink or for the gear to be worn. I have seen them fail when people try to put colored face plates. They can be quite delicate.

Good Luck.
 

·
Registered
2006 S500 AMG Wifes Rig Hillbilly Girl 02 ML320
Joined
·
2,332 Posts
Shady! That 90 300E I bought not long ago had same prob. I ended up sending the whole dash assem to a shop in Tex .They were able to rebuild for about $80 US ! The one fella who said get a used unit had the best solution for your prob!![:(][:(]

Smokie
 

·
Registered
SL320, 300e, 450SL
Joined
·
1,044 Posts
smokiesman - 5/3/2005 9:12 PM

Shady! That 90 300E I bought not long ago had same prob. I ended up sending the whole dash assem to a shop in Tex .They were able to rebuild for about $80 US ! The one fella who said get a used unit had the best solution for your prob!![:(][:(]

Smokie
Shady...I still say try to stay with original as it would bother me very much to not have original odometer. Original odometer= UNMOLESTED[:D]
Someone elses odometer= HEAVILY MOLESTED [:(][:0][:(]
p.s. Again, Fantastic camel you have there Shady![:p]
 

·
Registered
1994 E320
Joined
·
1,730 Posts
Discussion Starter #8
RE: Broken odo - FIXED!

Guys, thanks for the advice and links. I went out yesterday evening and got a couple of used clusters. But one of them had the same problem as mine, and I didn't even try the other. So last night, I decided to have some fun with the old unit, so I took it apart to figure out what was wrong with it.
I found that the spindle on which the digit rollers roll , and with a cog at one end which is run by a worm gear, had jumped off of its seat at one end, thus dislodging the rollers and the cog. I carefull realigned it and tapped it back into place, and everything was in order again [:)]
I'll post some pictures as soon as my wife gives me back my macro lens.
However...
Only one of the two used units I got is going back. The pointers on the one that had the same problem as mine had the nice, clean original orange color (as opposed to the discolored, yellow hands on my old one) so I'm thinking of fixing it up and keeping it. As a matter of fact, the discolored yellow is easier to see in the dark, which I like, but the orange just looks nicer and "newer."

Shady
 

·
Registered
SL320, 300e, 450SL
Joined
·
1,044 Posts
RE: Broken odo - FIXED!

Shady...Im glad you got it! Also, i thought you just announced your engagment a month ago or so? You marry already? Again, stunning [:0]camel you have there! BC
 

·
Registered
1994 E320
Joined
·
1,730 Posts
Discussion Starter #10
RE: Broken odo - FIXED!

Not yet [:(]
We were planning to get hitched in early June, but now we're considering putting it off till August. Got blindsided with a couple of things (long story,) but we'll work it out [:)]

Shady
 
1 - 10 of 10 Posts
Top