Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I was taking off the front airbox cover (the little one that is in front of the actual airbox) to put my K&N filters in and one of the little pieces that fits into the connector broke off. the one on the other side is ok but the side with the broken piece does not fit down very securely. Is this a big deal or should I try to super glue it or order another one? It seems to run fine and I think that when the hood is down it probably holds it in place pretty good. Any thoughts?
 

·
Registered
Joined
·
18 Posts
your hood doesn't touch your airbox at all... no car's hood does... there is a small gap. and you should just replace it... or look for one that someone is getting ride of /parting out... i know someone had some air boxes for sale on another forum. they were painted RED though. but yeah your car will run ok for a little while but you could cause some miss reads through your map sensor and cause a CEL to go off. SUPER GLUE wont hold under the Higher heat the Engine produces.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
It is not actually the airbox itself - it's the smaller plastic piece in front of that
that was loose - when i looked again I actually saw where I had not attached some of the other brackets on that piece so when I did that it fastened down quite securely. Before I saw this reply I did put the little broken piece back on with crazy glue and it seemed to be pretty solid. Ill check it in a few days and let you know how it's holding up. Even without that one bracket there are 4 others holdng it on so it seems to be pretty secure. The larger airbox itself is attached securely with all 4 brackets. I will keep an eye out for a new piece if I can find one.
 
1 - 3 of 3 Posts
Top