Mercedes-Benz Forum banner

41 - 60 of 97 Posts

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #41
Fuel line is replaced, new fuel filter and pump, new starter, CPS, and battery. Fuel pump isn’t making any noise. What should I do as my next diagnostic approach? Fuel pump relay K3 and Fuse 13 are ok. Also no fuel at fuel rail and red AAM light appears to be blinking which is a good sign.

Thanks for your help.
I also tested my 05 ML and when turned to position 1 the red light vlinks once every second for a good while and doesn’t stop. My 02 ML500 the light blinks a few times and stops. Could that indicate some sort of issue? Thanks
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
Test light would work but a multi meter s better. Pull fuse stick probe in the hot side of fuse do not be too forceful you do not want to bend the spring that clamps on the fuse lead then you need tho find a goof ground and ground black lead.

Can’t remember which fuse it is but it is left side f13 sounds right
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
I also tested my 05 ML and when turned to position 1 the red light vlinks once every second for a good while and doesn’t stop. My 02 ML500 the light blinks a few times and stops. Could that indicate some sort of issue? Thanks
Light blinking indicates the key is recognized I do know if amount of blinks has any meaning, no blink is very bad
 

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #44
Test light would work but a multi meter s better. Pull fuse stick probe in the hot side of fuse do not be too forceful you do not want to bend the spring that clamps on the fuse lead then you need tho find a goof ground and ground black lead.

Can’t remember which fuse it is but it is left side f13 sounds right
Should I do this with the key turned? And just measure for voltage? Thank You
 

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #45
I had a CEL for C1140 Steering Angle Sensor, could that have anything to do with the non start and fuel pump not getting power? Is the steering angle sensor the das ring that goes around the key?
 

Attachments

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #46
I also had the below codes maybe they mean something? Especially AAM codes? I got these using my iCarsoft i980. It’s not the best scanner but helpful.
C1140 Steering Angle Sensor N49
C1401 High Pressure Return Pump A7/3m1
B1088 CANbus: communication control A1 (instrument cluster)
B1981 CANbus: communication control N41 (travel computer) RRE module
B1041 CANbus: ESP/ETS
B1086 Canbus: AAM
B1089 Canbus: distributor linkage device
B1040-001: Canbus: ETS
P2315: one or more messages from control unit A1 are not available on the Canbus.
P2800: voltage supply of circuit 87 has undervoltage.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
On first start red light will bkink till you turn to start

Once started and turned off then restarted immediately it may blink once.
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
  1. If the fuse box cover is open and you go to start one hand on the relay and other turning the key do you feel the relay click. It is f13 k2 relay
It’s wired key to on-relay closes- then power to fuse the hot side is closer to center. The slot on that side is small if your probe is not small enough you will need something the thickness of the fuse blade to jab it with. May need some one to turn the key for you.

The brown wire bottom of fuse box is an active grounds are almost always brown!
 

·
Registered
Dallas, Texas
Joined
·
7,712 Posts
Fuel line is replaced, new fuel filter and pump, new starter, CPS, and battery. Fuel pump isn’t making any noise. What should I do as my next diagnostic approach? Fuel pump relay K3 and Fuse 13 are ok. Also no fuel at fuel rail and red AAM light appears to be blinking which is a good sign.

Thanks for your help.
How was K3 and fuse 13 tested?
What is AAM light?
 

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #50
How was K3 and fuse 13 tested?
What is AAM light?
I swapped K3 with horn relay that I know works and fuse 13 isn’t broken. When I put the test light on top of the fuse it lit up. AAM light I was referring to is the red light near the radio. Thanks
2632043
 

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #51
On first start red light will bkink till you turn to start

Once started and turned off then restarted immediately it may blink once.
Mine only blinks once that’s it. On the other ML it will blink continuously. Could that indicate a problem?
 

·
Registered
2003 ml500, 2004 ml350
Joined
·
1,532 Posts
Bossjj on this forum we usually refer to the light as the red led next to radio or console.
The official name is “indicator lamp for antitheft alarm system”

If anyone would know any more about one the blnking sequence it is Witek.

You had me curious so I tried it on the 500
After dealarming when I put the key in position 2 light blinks every few seconds

Position 3 light off

Position 0 light off

If I then go to position 3 again ( with out arming or not waiting for interior light to go off led only blinks once .
Position 3 light is off

You need a voltage meter even a cheap harbor frieght will do. Measure the voltage at the battery. MBs unlike most care are very voltage sensitive. If battery is not putting out 13 ish you could get a no start, but lights and all will still come on.
 

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #53
Bossjj on this forum we usually refer to the light as the red led next to radio or console.
The official name is “indicator lamp for antitheft alarm system”

If anyone would know any more about one the blnking sequence it is Witek.

You had me curious so I tried it on the 500
After dealarming when I put the key in position 2 light blinks every few seconds

Position 3 light off

Position 0 light off

If I then go to position 3 again ( with out arming or not waiting for interior light to go off led only blinks once .
Position 3 light is off

You need a voltage meter even a cheap harbor frieght will do. Measure the voltage at the battery. MBs unlike most care are very voltage sensitive. If battery is not putting out 13 ish you could get a no start, but lights and all will still come on.
It worries me that the light is only blinking once and not every few seconds continuously like other ML’s do. I know one blink is definitely better than none at all but I feel like that could be the issue. The battery is brand new so I doubt the voltage is an issue but I will check and post back tomorrow.
 

·
Registered
Dallas, Texas
Joined
·
7,712 Posts
I swapped K3 with horn relay that I know works and fuse 13 isn’t broken. When I put the test light on top of the fuse it lit up. AAM light I was referring to is the red light near the radio. Thanks
Fuel pump relay is F2k2.
2020-05-08_070138.png




Fuse F2f13 is after the relay. It should have power for ~2 seconds when key is turned to position 2. Then while cranking and of course when engine is running.
2020-05-08_063912.png






From fuse F2f13 power flows to connector X18 -> X18/3 -> fuel pump.
2020-05-08_064219.png
 

·
Registered
Dallas, Texas
Joined
·
7,712 Posts
I also had the below codes maybe they mean something? Especially AAM codes? I got these using my iCarsoft i980. It’s not the best scanner but helpful.
C1140 Steering Angle Sensor N49
C1401 High Pressure Return Pump A7/3m1
B1088 CANbus: communication control A1 (instrument cluster)
B1981 CANbus: communication control N41 (travel computer) RRE module
B1041 CANbus: ESP/ETS
B1086 Canbus: AAM
B1089 Canbus: distributor linkage device
B1040-001: Canbus: ETS
P2315: one or more messages from control unit A1 are not available on the Canbus.
P2800: voltage supply of circuit 87 has undervoltage.
Are those codes stored or current? Have you cleared them and reread? C1140 will not clear until engine starts and wheel is turned lock to lock few times.
New battery will loose voltage quickly. While scanning and doing other tests you need to have good battery charger connected.
 

·
Registered
Dallas, Texas
Joined
·
7,712 Posts
Bossjj on this forum we usually refer to the light as the red led next to radio or console.
The official name is “indicator lamp for antitheft alarm system”

If anyone would know any more about one the blnking sequence it is Witek.

You had me curious so I tried it on the 500
After dealarming when I put the key in position 2 light blinks every few seconds

Position 3 light off

Position 0 light off

If I then go to position 3 again ( with out arming or not waiting for interior light to go off led only blinks once .
Position 3 light is off

You need a voltage meter even a cheap harbor frieght will do. Measure the voltage at the battery. MBs unlike most care are very voltage sensitive. If battery is not putting out 13 ish you could get a no start, but lights and all will still come on.
My ML320 has marginal immobilizer coil. When it gets below 40 F it does not blink at all on first try. Blinks once on second try.
If I attempt to crank it without LED blink it starts and stalls after one second and sets code P1570 in ME.
 

·
Registered
(W163) 2005 ML 350 2002 ML 500 1999 ML 430
Joined
·
697 Posts
Discussion Starter #57
So what should I do next? I went to the junkyard and bought a immobilizer coil ring. I don’t know if it will help because the light blinks once only.
 

·
Registered
Dallas, Texas
Joined
·
7,712 Posts
So what should I do next? I went to the junkyard and bought a immobilizer coil ring. I don’t know if it will help because the light blinks once only.
Resolve issue with fuel pump first. Even if immobilizer is questionable engine will crank, start and stall.

With scanner look in engine live data for driver authorization.
 

·
Outstanding Contributor
2002 ML320, 2003 A160, 2002 ML500, 2018 GLS350d
Joined
·
4,405 Posts
Fuel pump only runs for 1 sec after ignition on, then while cranking/running engine. Is it cranking?

You need to bleed the air from the fuel line. Press in the stem of the Schrader valve while your friend cranks it, or bridge the fuel pump relay. Prepare to catch fuel as it squirts out at some point.
 
41 - 60 of 97 Posts
Top