Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
A-Class (W169)
Joined
·
53 Posts
Discussion Starter #1
Hi,

I have an 1.5 years old A-Class (A150 Classic) and i noticed when the brake pedal is pressed it squeeks...does somebody experienced this or might know why it happens? The sound comes from the pedal itself and the sound is not very loud but it still doesn't sound well :-(

Thanx!
 

·
Registered
A160 W168 /2002
Joined
·
546 Posts
lofty

Why do anything other than take it back to MB, you still have 18 months warrantee. I suspect that in the last twelve months you have also had a service so if it wanted lubricating at intervals it should have been done on that service they charge enough.
 

·
Registered
A-Class (W169)
Joined
·
53 Posts
Discussion Starter #4
I took it back to MB and they said "it was normallly caused by the brake fluid compression - so it was normal". They applied (or so they say) a lubricant ti the pedal but it is the same..SO all in all they said they couldn't do nothing.

It is not a big issue since it is not a loud noise, but it was not there before...
 

·
W203, W210 Moderator
E55 ///AMG
Joined
·
6,911 Posts
SirOracle said:
I took it back to MB and they said "it was normallly caused by the brake fluid compression - so it was normal". They applied (or so they say) a lubricant ti the pedal but it is the same..SO all in all they said they couldn't do nothing.

It is not a big issue since it is not a loud noise, but it was not there before...
IMO If the squeaking noise is not there before then its not normal, that dealer of yours is giving you a BS go to another reputable one.
 
1 - 5 of 5 Posts
Top