Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #1 (Edited)
i redid all four calipers with repair kits a couple months back but its been sitting ever since. today i was in line for fourth meal at the drive through and they cannot make tacos fast enough so i was sitting in one place for like 3 minutes in D. as i let off the brake what sounds like the l/r scrapes really loudly.

it did that a couple times but not if i put it into neutral as i was pulling up behind the car in front. as i drove off with my food the noise lasted for a couple seconds and went away. the next stop sign i braked really softly, and as i hit the gas the car kinda jerked and then started moving, not much but i felt it.

what can i do to remedy this? i have never noticed it until now so i guess i can live with it as long as i drive normal.
 

·
Registered
2013 SL550 Grey/ Red/Black Ash wood with every option
Joined
·
416 Posts
viper, did you replace the rubber brake hoses? If not that's where I would start to remedy the noise. Please let us know what you find.......Thor
 

·
Registered
EURO 280CE
Joined
·
1,689 Posts
Discussion Starter #3 (Edited)
the flex hoses i replaced. i took off a rear rotor today and it didnt look good. on the outside where the parking brake shoe is is bright blue from the heat, i took it off and there is a small amount of dust but alot for only driving about 100 miles.

i have no idea what i did wrong, the adjusters for the shoes are all the way in i never adjusted them. the wheel spins free up in the air, no grinding. when i pess down the parking brake i can see the bottom of the shoes pressing out and back in after releasing. the shoes arent directional each one is the same, so they cant be backwards. i did notice i couldnt turn the adjuster screw at all. i know it was taken out and cleaned so im not sure whats up there.
someone help i dont want my car to start smoking down the road.
 
1 - 3 of 3 Posts
Top