Mercedes-Benz Forum banner
1 - 20 of 23 Posts

· Registered
Joined
·
12 Posts
My speedometer needle bounces at all different speeds until I push the instrument cluster ...

My speedometer needle bounces at all different speeds until I push the instrument cluster in. Then it works perfect, no bouncing. But I'm not going to sit there pushing on the cluster the whole time so I am probably going to go out to my car in a minute and see if I can tighten it or something.

Oil needle bounces when I start my car. Drops down when I idle, goes back up when I accelerate. That's weird.

The fuel needle has bounced a little bit but not too much.

I think my 85' Benz 190E is possessed.
 

· Registered
S430,190E 2.6,SL500
Joined
·
194 Posts
bouncy speed and fuel guages

my 1985 190E 2.0 has a bouncy speed and fuel guage but only at low speeds (below 30mph) and when its almost out of fuel

my 1992 190E 2.6 has a boucy speed at less than 20mph since i bought it new 10 years ago
 

· Registered
Joined
·
67 Posts
If you have a boucy needles time to replace your speedo cable.Might as well put some white...

If you have a boucy needles time to replace your speedo cable.Might as well put some white gauge face on it.Here's the link on how to remove cluster.

http://www.geocities.com/ronaldnjoy/index.html
 

· Registered
Mercedes 28E 1993 (W124)
Joined
·
119 Posts
bouncy needle!!

mine does it as well!! but only at low speeds. All the merc owners i know have the same prob....maybee its just a typical thing of mercedes? The speedos arent electronic are they.? might this explain it?
 

· Registered
'85 2.3-16 '99 C280 '11 GLK350
Joined
·
4,803 Posts
The speedo is cable driven from the transmission. Bounce generally means the cable needs to be checked, and given the fact that the only service you can do to it is to refasten the ends, it probably needs to be replaced.
 

· Registered
S430,190E 2.6,SL500
Joined
·
194 Posts
I got the whole speedo set on my 85 190E replaced today and it became the first time in 19 years that it didn't bounce. I guess Mercedes-Benz has long figured out the problem has has since fixed it for their reproduced parts. Try getting yours replaced, it's less than $250
 

· BenzWorld W126 & W201 Host
1988 420SE, 2002 C180 Kompressor, 200 ML320
Joined
·
1,150 Posts
This has always been a common problem and is usualy caused by the cable getting stretched when the cluster is removed.

This is worth bearing in mind if you need to replace any cluster bulbs. Only pull the cluster out the absolute minimum possible to get your hand in and disconnect the cable or better still try to disconnect it from underneath and then take the cluster out.
 

· Registered
190E Benz
Joined
·
109 Posts
I also had the same problem with the speedo needle. Ive only had my car for around a month and it bounced constantly for about the first 2 weeks, but it has now settled down and doesnt move much at all [:I] Weird i thought!?
 

· Registered
190E Benz
Joined
·
109 Posts
my speedo is out too i think [:(]
I seem to go so much slower than everyone else does at the same speed. I notice it more so out of town, EVERYONE overtakes me [:(!] If i had to guess, id say its almost 10kms out. Either that, or everyone else is speeding [:D]
 

· Registered
2002 E430 4MATIC
Joined
·
18 Posts
spanners - 12/9/2003 4:14 PM
Only pull the cluster out the absolute minimum possible
hmmm...maybe i should stop taking it out for fun then...

:D j/k but i have removed it way more times than i should have. My "new" speedo cable is streched.

One more thing to note: if your cruise control "hunts" or is jerky and you notice that your needle is bouncing (even slightly) you can likely fix your cruise by replacing the speedo cable.
 

· Registered
The "GENERAL"
Joined
·
366 Posts
I am getting the impression that the inside of the speedometer cable and/or mechanism for the speedometer itself is "drying out" due to lack of lubrication...[probably the speedometer mechanism]

For the do-it-yourself-er...

Remove speedo cluster from dash... spray "WD40" or equivalent into the 1.speedometer cable... 2. speedometer mechanism...

Unwanted side effects 1.*WD40 introducing itself to the transmission via the speedometer cable... 2. a greasy looking speedometer gauge from WD40 overspray/runs...

*Probably would not hurt a manual transmission... not so sure about an automatic transmission...
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top