Mercedes-Benz Forum banner
1 - 20 of 22 Posts

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #1 · (Edited)
i have about 49k miles
when at idle about 600 rpm i press gas pedal slowly and i get to about 1200rpm and hold the pedal there, the rpms drop and there is a roughness. if i just rev over that, engine seems fine. the car has sat for about 4 months. could this be fuel filter or a plug or maybe a fuel conditioner?i did fill with 10 gallons of fresh fuel. i have no trouble codes present.:confused:
todd
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #2 ·
after further observation, i do see and feel a slight tremor in the engine at idle
 

·
Registered
2001 S430
Joined
·
419 Posts
sounds like limp mode, could be a few things, have you had it checked for codes at a dealer? via star Diag.
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #4 ·
hi and thanks
yep, no codes with das. just bought a spark plug cleaner, so now i need the boot remover or i might just try the 17mm but rather have the right tool! i also ordered new fuel filter since required around 50k anyway but i dont wanna guess and this benz i purchased salvage and until i fix the quarter panel, i cant drive it. but i have star das and no codes.:confused:
todd
 

·
Registered
2001 S430
Joined
·
419 Posts
There is an active thread in here where eric explains that while in park there is a rev limiter on the car that will not let you rev above a certain rpm. keep us posted.
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #6 ·
thanks for the thread
it revs fine after 1300rpm all the way to about 5k rpm with no bog down
 

·
Registered
2004 Mercedes-Benz S55 ///AMG, 2006 Mercedes-Benz E350
Joined
·
685 Posts
If the car was in storage for 4 months in PA, the fuel might have turned into gunk. Try smelling the fuel in the tank to see if if smells normal or take a little out of the tank via a hose. Bad fuel smells like turpentine. If fuel is old, get as much as you can out of the tank and fill up with fresh gas.

The last time I was at MB Dealer, overheard an older woman talking to the Svc. Advisor re her car. A rat had carried bits of dog food into the exhaust, lots of it, which had clogged the exhaust and had caused the engine to run badly and stall at higher RPM.

I am not saying this is your issue but 4 months of storage could have caused something to not be right. Do an all around check of the car, under the hood, etc. and look for anything unusaul.

Good luck!
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #10 ·
thanks
i have refilled with 10 gal of fresh gas since almost empty. dog food huh:eek:
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #12 ·
after further observation. i found i hear a sputter from exhaust at idle and the bogging down happens intermittently but more than not. it starts around 1k rpm and 3k rpm. if i hold the pedal in this area, it bogs down about 1k to 1500rpm and engine shakes. i have yet to clean and check my plugs awaiting plug boot remover. i have replaced fuel filter, air filter and oil change. gas is fresh. still waiting on my ftpv as well. i have no codes:surrender:
thanks
todd
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #14 ·
the opposite!
as i press the pedal and hold it anywhere between 1k rpm and 3k rpm it surges and shakes. anything above that seems fine.
any ideas?
i checked a few plugs and they looked and smelled ok. i it happens when driving as well. i hold it there surging for a while hoping to throw a code, but no codes. no codes for air flow sensor or oxygen sensor or anything. this is my last problem with the car and it bugging me:confused:
todd
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #15 ·
i have performed a couple of test with das
air flow sensor ---ok
right oxygen sensor---ok
left oxygen sensor----ok
all fuel injectors-----ok
ftpv----ok
the problem seems to happen after car warms up!

this is bugging me:surrender:
todd
 

·
Registered
2001 S430
Joined
·
419 Posts
Possible fuel pump? is the pump in the tanks on these cars? The fuel filter would cause it to starve at higher rpm and would be consistant.
 

·
Registered
2003 s430 4matic
Joined
·
174 Posts
Discussion Starter · #17 ·
yeah thanks
the test came back ok on that too!
i tested a few things like the cats, injectors, tank pressure, oxygen, purge valve and they all checked out ok according to das. next test will be crankshaft position sensor. i am still waiting for my plug cleaner and one of the symptoms in the troubleshooting are is the FTPV as a possible problem. although it passes on the das, it still is very loud and gonna change it anyway.
todd
 

·
Registered
02 S500
Joined
·
121 Posts
I had the same symptoms, lots of hesitation when I bought my car from very famous dealer thinking that my car would have no problem but guess what happend when i opened air filter assembly. It was mess in there, the air filter was almost shredded and lot of junk there. I cleaned it and put the new air filter and after that my problem was gone..
 

·
Registered
2001 S430
Joined
·
419 Posts
yeah thanks
the test came back ok on that too!
i tested a few things like the cats, injectors, tank pressure, oxygen, purge valve and they all checked out ok according to das. next test will be crankshaft position sensor. i am still waiting for my plug cleaner and one of the symptoms in the troubleshooting are is the FTPV as a possible problem. although it passes on the das, it still is very loud and gonna change it anyway.
todd
:thumbsup: great info keep us up to date.
 
1 - 20 of 22 Posts
Top