Mercedes-Benz Forum banner

21 - 39 of 39 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #22
Just ordered a tune up kit which includes plugs,wires, distributor cap, distributor rotor as well. Looking into an injector kit because I took each fuel line off the FD and saw dirt in each cylinder which has me thinking these injectors are all leaking/always opened up.
 

·
Registered
1991 560sec. 1969 280SL
Joined
·
1,131 Posts
You need to flush out your fuel supply and return lines as well as what John has suggested.
 

·
Registered
1990 420 SEC
Joined
·
235 Posts
If you saw dirt at FD ports then most probably fuel distributor membrane has burst as dirt goes downstream. That you would notice if you had fuel pumps running and injector lines off.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #25
I replaced spark plugs and wires today, running better but still alot of black smoke. I replaced the plus last week and it seems like all of them are fouled. They were all black. Gonna pull the injectors when I'm off again. Should I get new ones ? Should I not pull them off and run fuel system cleaner such as seafoam ? Or just clean the ones I have at a shop?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #26
If you saw dirt at FD ports then most probably fuel distributor membrane has burst as dirt goes downstream. That you would notice if you had fuel pumps running and injector lines off.
Can you send me a picture of which ports on the relay to jump?
 

·
Outstanding Contributor
350SDL, '17 GLS450, "Grandpa's Roadster" Project Car
Joined
·
3,163 Posts
If all the plugs are equally fouled then there's a better chance it's something all cylinders have in common.
 

·
Registered
Joined
·
5 Posts
I would also check the coils, I had a similar issue and as the car was ran longer the coil started to drop out. Just something to think about.
 

·
Registered
Joined
·
12 Posts
Hey Zack,

Welcome aboard BW!!

How frustrating to have all those issues straight off!

I had had some rodent activity in my 560 air filter housing over one winter. It was a mess in there.. The mice came up the air intakes Martin refers to.. Built a big nest and chewed on the filter media.. I can envision a mouse nest up in there, definitely worth a look.

Keep us posted on what you find & good luck.

MBL
After sitting for 6 years, rodent activity would be the first thing I would check.
Next would be fuel line deposits from sitting.
Good luck !
 

·
Registered
Joined
·
2 Posts
I’m watching this post. I have a similar situation, 560SL that has sat for several years. Drained the tank, blew out the lines, replaced the filter. It won’t idle longer that 10 seconds but after several attempts there was fuel running out the exhaust. Seems better after soaking the injectors in sea foam for several days and blowing through them. Still won’t run more that 10 seconds though. Figured out my screen in the tank is still clogged, once I get the tank out and cleaned I’ll see what it does. Oh, I also replaced the fuel pump relay. I found it best to create a battery to fuel pump and accumulator at the back of the car. If your going to jumper at the relay it’s 30 to 87 I think
 

·
Registered
Joined
·
13 Posts
Discussion Starter #31
If all the plugs are equally fouled then there's a better chance it's something all cylinders have in common.
Fuel pressure regulator maybe? No leaks coming from that little plastic tube that's on it but who knows. Still searching for my golden ticket lol
 

·
Registered
1990 420 SEC
Joined
·
235 Posts
Fuel pump relay jumper:

It is sockets 7 and 8. Pins 30 and 78 of the relay go to those. When the pumps are running you should hear fuel flowing trough pressure regulator and back to tank. Cold start injector should not spray. When measuring plate is deflected fuel should flow out of the ports of the distributor to injectors.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #34
Csv doesn't spray with pumps on, could it be my main ignition coil?? Forgot to mention but it has no power to move the car I have to hit the gas to get it move an inch.
 

·
Registered
1990 420 SEC
Joined
·
235 Posts
So did you check if distributor is leaking fuel from ports to injectors as fuel pump is running and air metering plate is not deflected?

You can check coil by of measuring resistances its primary and secondary.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #37
I
So did you check if distributor is leaking fuel from ports to injectors as fuel pump is running and air metering plate is not deflected?

You can check coil by of measuring resistances its primary and secondary.
Haven't yet, the weather here is atrocious but I will when it warms up
 

·
Outstanding Contributor
350SDL, '17 GLS450, "Grandpa's Roadster" Project Car
Joined
·
3,163 Posts
Have you run a pressure test on the control pressure? I think you said it runs better cold; maybe it's not compensating for the warmer engine.
 
21 - 39 of 39 Posts
Top