Mercedes-Benz Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,408 Posts
Discussion Starter #1
I'm getting air out of the defrost vents in all settings on the climate control.

I assume that there is either a bad pod or lack of (enough) vacuum. Is there anything else that would cause this? Or at least know the easiest way to get to that pod to check on it?

It's not a huge deal in the winter, but once it's A/C time again, I'll be getting a frosty windshield.
 

·
Registered
Joined
·
2,639 Posts
There are five vacuum actuators behind the switch panel above the AC/Heater control. I've heard these "rarely" go bad. However, I had two go bad, then when getting used replacements, it was about 35% bad. These actuators direct the vacuum to the vac pods as directed by the climate control unit. You can get in there and test your vac pods, if you have a Mity Vac. The nipples pointing straight out are the ones going to the pods. The #2 & #3 (left to right) pods affect the center and floor vents. Connect the Mity Vac to the #2, pump it up to 25 and turn on the fan. If you get air from the center vents the vac pod should be OK and you may have a bad actuator. If you loose vacuum or it doesn't hold, your pod may be bad. The actuators are held in by two Phillips screws each.
Here is a GREAT write up by "Gregs300CD"
http://www.benzworld.org/forums/w123-e-ce-d-cd-td/1344511-acc-vent-vacuum-control.html

EDIT: ...and be careful in there as not to knock some other vacuum connection loose while your testing.
 

·
Registered
Joined
·
1,408 Posts
Discussion Starter #3
Thanks for the info/link

would weak vacuum in general cause some of these pods to not function normally. I'm thinking I need to start by testing the vacuum off the pump and working my way back. I *really* don't want to pull the dash yet.

main vacuum should be???
 

·
Registered
Joined
·
1,279 Posts
Check your locking system as well. Any vacuum leak can cause other vacuum consumers to not operate properly. My HVAC is unplugged right now because of bad vacuum pods.
 

·
Registered
Joined
·
1,248 Posts
The vacuum element that controls the defrost is on the driver's side just above and to the right of the throttle peddle. You can see up there it with the lower dash panel off. With a mity vac, you can test it to see if there is a leak. If not then you may have to go through the whole system, locks included as Ralph suggested.
 

·
Registered
Joined
·
1,248 Posts
There are five vacuum actuators behind the switch panel above the AC/Heater control. I've heard these "rarely" go bad. However, I had two go bad, then when getting used replacements, it was about 35% bad. ....
Personally I would of rebuilt them getting the diaphragms and the 10 dollar special tool from George of Performance Analysis as noted in the link.
 

·
Registered
Joined
·
1,408 Posts
Discussion Starter #7
OK, if it's the one above the throttle pedal, then perhaps I knocked it when I had the lower panel off recently. I'll check there first.

what should the vacuum Hg be right off the pump?
 

·
Registered
Joined
·
6,118 Posts
right off the pump you want about 20-22in
 

·
Registered
Joined
·
2,639 Posts

·
Registered
Joined
·
2,700 Posts
If your push button unit is bad it will do the exact same thing so start with your vac like everyone says and if no luck try to swap out the unit with another......i know it maybe be hard to find but they dont last forever so if you know it works its worth it to have around for when yours does go bad.


BTW taking the dash off isnt that bad its just if you have to drive somewhere that sux when its off.

Also if anyone else needs one let me know i have a bunch of working ones and at near a grand for a new one cheap used ones look better and beter all the time.
 

·
Registered
Joined
·
10,152 Posts
Also if anyone else needs one let me know i have a bunch of working ones and at near a grand for a new one cheap used ones look better and beter all the time.
My '83 SD needs one, that's it, in the pic. Don't know what the pin count is.
The one I got used, is different.
 

Attachments

1 - 13 of 13 Posts
Top