Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
1991 Mercedes 560SEL
Joined
·
7 Posts
Discussion Starter #1
When balance is set to the right side the sound is good. When balance is set all the way to the left, the sound is poor in all speakers on that side, crackling and weak.

Have swapped the amps behind rear seats(W126). No change. Could this be speakers on one side only? Wiring? Bad radio?

Has anyone had this situation?
 

·
Registered
CLK55/G500/E55/ML55/etc.
Joined
·
1,242 Posts
Check the connector going into the stereo. It might be loose/weak wiring at that point, t...

Check the connector going into the stereo. It might be loose/weak wiring at that point, that goes to the amps. Actually, the wiring at any point between the stereo and the amps is suspect, but failures are far more likely to occur at/near the connectors. Try wigging things around while the system is producing poor audio. Also, the power going into the amp may be reduced, resulting in poor amplifier performance.

-s-
 

·
Registered
92 500SEL to 01 E320T current 2014 lexus LS460
Joined
·
3,886 Posts
crackling sound

If you have the "bose system" it is probably the amp, it is a common problem, I thought it was a speaker and took the door apart, also swapped the outputs. "bad amp" there are some rebuilts out there, and Becker offers a exchange/repair program. I am not familiar with what your car/year, but it is common with 140 body S500 etc. $500 if not I think Becker also offers radio exchange program, check the web they have Q&A
 
1 - 3 of 3 Posts
Top