Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2001 SLK320 and just replaced a dead battery. I turned on the car and the BAS/ESP light is now on and it wasn't before the battery was dead. Is there something I need to do to reset the light?

I'm hearing something about turning the wheels lock-to-lock will reset the sensor but tried that and no luck.

I know a lot of cars have a way to reset the lights by turning the key to position 2 while pressing another knob for x seconds. Not sure if Benz's have this or not but thought I'd toss it out there in case someone knows.

Any idea guys?

Jeff
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I just tried turning the wheel far left and far right again and this time the light turned off. Thanks Jara!

Jeff
 

·
Registered
2001 SLK 320
Joined
·
26 Posts
Just wanted to say that this was a lot of help to me.

I disconnected the battery in my 320 to reset the CEL and when I restarted the car the BAS/ESP light came on. Did a quick search on here and once I turned the wheel all the way to the left, then all the way to the right and back to center the light went off.

Thanks for the help!
BJ
 

·
Registered
2001 SLK320
Joined
·
139 Posts
Ditto on the thanks. Came out, turned the key, lights but no start. Looked like OE battery so 10 yrs old, no surprise. checked this forum for any insights or tips when having to change it out, found this thread, bought battery, swapped it out, started it up and sure enough the BAS/ESP light stayed on. Turned it off, turned key to #2, rotated steering wheel all to left then all to right then center, started up again, lights went off, entered my radio code and all was back to roses.
Thanks!
 
1 - 6 of 6 Posts
Top