Mercedes-Benz Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1 (Edited)
Hi
I had to recharge the battery while on the car with a charger, as it run flat on me after letting the music on for 1/2 hour with the engine switched off.
When charging was completed some functions gone weird.Parktronic comes on when it shouldn't some functions of the computer on the dashboard show just a flat line.
Something needs resetting here.Does anyone knows what is happening?Do I have to take it to the dealer to put it on the "Star diagnosis" and erase the errors?
Thank you
 

·
Registered
ML550, W212 E350 4 matic, 1966 Corvette C2 convt.
Joined
·
2,675 Posts
a half hour of radio use should not have killed the battery. In addition with the key off and radio on I believe that the radio will shut itself off in less than a half hour to prevent what happened to you. I think that all the items that you mentioned must be reset by a dealer if the battery is disconnected. You also could have connected the charger without disconnecting the battery. Suggest also that you may need to have the battery replaced so have it checked out when you go in for the resets.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #4
a half hour of radio use should not have killed the battery. In addition with the key off and radio on I believe that the radio will shut itself off in less than a half hour to prevent what happened to you. I think that all the items that you mentioned must be reset by a dealer if the battery is disconnected. You also could have connected the charger without disconnecting the battery. Suggest also that you may need to have the battery replaced so have it checked out when you go in for the resets.
Thank you Sosh for your remarks.
I should had stated that I upgraded my music at one point,so the amplifier,subwoofer and other equipment surely wears battery faster.For some reason also key must be on for the system to work.Yes you are right,charging can be done without removing the battery,but as this happen in the country,on our Easter Sunday,I tried removing the battery first(only removed neg pole)and then I got hold of the neighbours charger.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #6
That's the reason your battery went flat, not use of the stereo.

Here's why you don't need to remove the battery for charging...
Thank you for your answer.As I said, at the begining I couldn't get hold of a charger or wires,so I had to remove the battery to take it for charging.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #8 (Edited)
What Year and Model ML do you have?
Mike
Nov. 07 320cdi.
Took it at the dealers yesterday.Put it on Star diagnosis and they said everything is sorted.It wasn't easy,up to the point that they thought is a more serious issue,damaged cpu or something.As they said this was caused by removing the pole(negative) and then almost straight away putting it back.However on the same afternoon the parktronic right front sensor started bazzing for no reason again!
 
1 - 8 of 8 Posts
Top