Mercedes-Benz Forum banner

1 - 12 of 12 Posts

·
Registered
84 190D
Joined
·
398 Posts
Discussion Starter #1
Hey all...Today my battery light came on for the first time ever here is what I see

light came on
dull @ idle
brighter w/ increasing revs
back to dull at idle
brighter with power window use
dull @ idle after ~5sec

battery 13.06V
@ glow plugs- down to 3V
Start- 11V
Idle- 14V
Rev to apx 3000 ~16V
Idle 14V
off 13V


What could be causing the light issue?

The alt is charging but is is charging to much?

What are your values?

Thanks

-JB
 

·
Registered
1990 190E 2.6
Joined
·
76 Posts
Do you have a brand new batt? maybe your battery is going out, or maybe its your alternator dying idk
 

·
Premium Member
'92 MB W201 2.3, '10 MB X164 GL550 4Matic, '14 MB W218 CLS550 4Matic
Joined
·
911 Posts
i think alt issues....

idk but how can you check alt charging while it's in the car?
NEVER... REPEAT.... NEVERdisconnect the battery leads trying to figure out whether the alternator is working or not as this will fry many of your electronics

Check:
1-The battery at your local parts store if it is still good and accepts charging or already dying
2-The volatge regulator and brushes assembly attached to the alternator
3- I would check the OVP
 

·
Registered
84 190D
Joined
·
398 Posts
Discussion Starter #5
update:

battery at 13.6V
on startup drop to 11V
idle climbing slowly
rev 1000 14.5V
rev 1500 16V
rev 3000 17.8V
now idling and climbing slowly to 14.36+V


light gets brighter with higher revs...


could my alt be putting out to many volts and over charging the bat causing the light issue?
 

·
Premium Member
2004 CLK 240 Coupe
Joined
·
11,370 Posts
Assuming that you are measuring these voltages at the battery terminals, your voltage regulator should prevent the alternator sending voltages over 14.0 (or so) volts.

Looks like you have a problem in that area...
 

·
Premium Member
'92 MB W201 2.3, '10 MB X164 GL550 4Matic, '14 MB W218 CLS550 4Matic
Joined
·
911 Posts
ok so looks like it was the AVR...not even


any ideas where to get one? Dealer wants $95
Ontario?? hmmmm .... Check AutoValue, I purchased mine from them 2 years ago for $16 CAD as long as I remember
 

·
Registered
84 190D
Joined
·
398 Posts
Discussion Starter #10
OK so new voltage regulator installed
no change
still goes to 17.8V @ 2000 rev


No OVP in k1 or in the hidden area behind battey

so...whos got ideas?
 

·
Registered
84 190D
Joined
·
398 Posts
Discussion Starter #11
update:

swapped out alternators with new AVR...charge @ 12.12V @ 2000rev
old AVR...charge @ 12.12V @ 2000rev

now glow plugs do not work....
 
1 - 12 of 12 Posts
Top