Mercedes-Benz Forum banner
1 - 12 of 12 Posts

·
Registered
1998 E320 RWD Metallic Black; 2006 BMW 530xi; 2011 E350 4Matic Sport
Joined
·
295 Posts
Discussion Starter · #1 ·
Hello,

During the past two weeks I have been getting the red battery sign in the center screen of my instrument cluster. This is followed with an immediate Command shutdown, climate control shutdown and seat heater shutdown. Pretty much all major electronic gizmos go on hibernate. The first time I ignored it and thought the battery might be suffering from the Polar Vortex conditions. Second time I didn't give it too much thought and just restarted the car and drove on.

This morning the symptoms came there to stay and off I went to the $tealer. They diagnosed and found out faulty alternator module and weak starter battery. Dealer will replace complete alternator assembly, serpentine belt, starter battery and auxiliary battery. Apparently, as per my service advisor, there is an open case with MB AG, and current fix is the replacement of all of the above.

Just wanted to share this info with you in case members of this forum experience similar symptoms.
 

·
Registered
1998 E320 RWD Metallic Black; 2006 BMW 530xi; 2011 E350 4Matic Sport
Joined
·
295 Posts
Discussion Starter · #3 ·
Yeah, I can only imagine ... . I would think shy of a coupe of grands. It's been good to me so far, no issues whatsoever. Will pick it up tomorrow PM. It is very strange that alternator would die with only 46K miles on :-(.
 

·
Registered
2011 E350
Joined
·
202 Posts
...Apparently, as per my service advisor, there is an open case with MB AG, and current fix is the replacement of all of the above.....
I haven't had any symptoms but in monitoring my battery health I've noticed the battery can't keep a decent charge. It stays around 25%, or lower with a couple weeks of short trips. Long trips charge it to only 75% and it takes just days to drop to 50% then to 25% where it hovers. A trickle charger takes it to 100% but it doesn't last long regardless of how much I drive....with lights off. Did he mention anything about the nature of the "open case"?
 

·
Registered
2012 ,W212 Mercedes-Benz E Klasse
Joined
·
646 Posts
Sorry to hear about problems with your car , I can see a failing battery but alternator issue sounded a premature problem or bad luck considering age of your car
Looking forward to hearing your car is back and running like new
 

·
Registered
1998 E320 RWD Metallic Black; 2006 BMW 530xi; 2011 E350 4Matic Sport
Joined
·
295 Posts
Discussion Starter · #7 ·
Yes, a pity. Got the car back an hour ago with all the things mentioned replaced. I am not that worried, really. I extended the CPO warranty for 2yrs/135K miles so I will be $et for another 3.5 years :).

MAE320...was this on your 2011?
 

·
Registered
1998 E320 RWD Metallic Black; 2006 BMW 530xi; 2011 E350 4Matic Sport
Joined
·
295 Posts
Discussion Starter · #8 ·
Yes they mentioned that they have not pinpointed the problem with 100% certainty and for every instance of this happening they have to send a set of data to MB. Current guidance calls for replacing all of the above. I get the alternator and the battery but the serpentine belt is a mystery ....

I haven't had any symptoms but in monitoring my battery health I've noticed the battery can't keep a decent charge. It stays around 25%, or lower with a couple weeks of short trips. Long trips charge it to only 75% and it takes just days to drop to 50% then to 25% where it hovers. A trickle charger takes it to 100% but it doesn't last long regardless of how much I drive....with lights off. Did he mention anything about the nature of the "open case"?
 

·
Registered
Joined
·
20 Posts
Disappointed

Picked up the car from the dealer yesterday and all they did was replace the alternator with a Remanufactured one! The car is still under factory warranty.

Week before my wife brought the car in for it's 20k mile service which cost $524. without the brake flush! When asked why the brake flush wasn't done the dealer said he didn't know.

I will be trading my E350 in for a new Audi A6 3.0T.

I'm done with MB.
 

·
Registered
2014 E350
Joined
·
13 Posts
Picked up the car from the dealer yesterday and all they did was replace the alternator with a Remanufactured one! The car is still under factory warranty.

Week before my wife brought the car in for it's 20k mile service which cost $524. without the brake flush! When asked why the brake flush wasn't done the dealer said he didn't know.

I will be trading my E350 in for a new Audi A6 3.0T.

I'm done with MB.
What a coincidence. We are done with Audi for the same reason - poor dealers.
 

·
Registered
2014 E350
Joined
·
4 Posts
My recommendation is to call MBUSA, they have fixed alllll of my issues. The dealers are either great or mediocre at best....that really shouldn't sway your decision to spend thousands of dollars trading out of a car (trust me, I incurred thousands of dollars switching from a 2010 E to 2011 E simply because they dealer sucked at doing their job. Now, I have a 2014 E and I had some issues out of which I left the dealer out of it because they couldn't fix a problem properly, after several trips to the dealer, they finally got it....and what did I get out of it? Several services.for free from MBUSA along with an extension for my Mercedes Benz Apps along with Mercedes benz concierge. So buddy, don't blame the car, or brand, for the dealers shortcomings...trust me, when you deal personally with THE Mercedes Benz, you will completely forget whatever problems you had.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top