Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi im new to the forum name Lebo from S.AFRICA i have 97 c280 my battery was stolen and wires cut i joined them , replaced the battery it started and switched off and try to start but the battery was drained i dont know where to start. i do not know if there was damage done when pos+ wires were cut shorted something. Thank you in advaNCE
 

·
Registered
Joined
·
880 Posts
Are you saying your battery went dead immediately after starting car and shutting it off?

If so, I'd check the connections you made. Did you solder the wires together?

Was the battery you installed new and charged up?

What is the battery voltage at the battery terminals?

Measure the battery voltage while someone tries to start car.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Thanx Marvin for propt reply i drove for more 30min, its new batt fully charged it measured 13.2v .i used feriles to join wires and soldered connections , i will check the voltage as you suggested maybe i must trace the three positive wires connected to the +terminal , i will keep you posted thanx once more
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
hi Marvin yesterday i got it right after checking wires running from the batt only to find the neg- terminal was not making good contact although it was tight. i put back bekker radio and it pointed me to right direction , it happened ago when it fitted JVC radio i used wrong ground wire the sound was bad. it did same with original radio.thanx once more
 
1 - 5 of 5 Posts
Top