Mercedes-Benz Forum banner

1 - 3 of 3 Posts

·
Registered
2006 E320 CDI
Joined
·
262 Posts
Discussion Starter #1
Just picked up a second E320 CDI, year 2005. I already own a 2006. I'm looking for some insight on a battery drain issue and I suspect the comand system is involved.

The battery has a steady slow power drain when it is shut off. The battery will get down to 11.5 volts in about 3 days without a trickle charger on it. I've noted some suspect things.
  • The Navigation DVD drive in the trunk seems to kick on every 15 minutes, even if I just open the doors to the car.
  • There is a navigation disc in it (2005 version), but it doesn't read it. This makes is suspect that the drive is bad.
  • I noted that once, the Comand head didn't turn off after I had turned the car off and it sat for 30 minutes. It only did this once that I've noticed.
Since the Nav on these cars is pretty dated, I'm OK with just disconnecting it. Don't know if that will solve the problem on the slow power drain. I can pick up a second Nav drive and control head at the local junkyard as well. I will probably replace the head unit eventually with an aftermarket unit, but for now, I'm just troubleshooting the power drain.
 

·
Registered
Joined
·
3 Posts
Check for water damaged amplifier in the left rear wheel well . You will need socket set and torx screw driver . It's easy … Monkey see monkey do . I KNOW first hand experience ...
 

·
W221 & Audio Moderator
2013 S550
Joined
·
10,872 Posts
1 - 3 of 3 Posts
Top