Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I recently bought a 99 C230 Kompressor with 165K miles on it, since I bought it, the BAS ESP light is constantly on. When I turn on the car the light is off, and even when I drive it stays off, the light only comes on after the first time I break and then stays on till the next time I turn it on. I have tried to avoid breaking but after a few miles it becomes inevitable. I have driven it for about 3K miles now and aside from the engine seemingly running a but loud it drives (and breaks) just fine.

I have scoured this forum and the internet for a solution and found a lot of BAS ESP light issues but each seemed to come with actual symptoms, while I seem to have none. I have tried the turning the steering wheel all the way to the left, then all the way to the right twice but no go.

Any ideas?
 

·
Registered
Joined
·
2 Posts
BAS/ASR light will come on when the brake light switch is going bad. Replace the brake light switch that is pressed by the brake pedal and it will stop. Cheap and easy fix.
 

·
Registered
2002 ML55 AMG, 2005 Chrysler Crossfire Coupe Limited, 1999 C280
Joined
·
4,714 Posts
The brake light switch is a first, cheap approach to this problem and hopefully is your solution.

Other problems which can cause this light to illuminate are rather more expensive to rectify.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks everyone for your response. Indeed it was the Brake light switch and it was very easy to replace.. im not the most mechanically inclined and it still only took me about 20 mins.

I had noticed that the cruise was also not working, so when I searched for the BAS + cruise all threads seemed to point to the Brake Light switch... putting in a new one took care of the BAS light, which I am really happy about, but seems like cruise still doesnt work.
 
1 - 5 of 5 Posts
Top