Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
W211 E55 AMG
Joined
·
50 Posts
Discussion Starter #1
Hi all,

I have read this abs bas warning lights problem on here a number of times, and I myself have suffered this problem once after a jumpstart (the steering left to rihgt cleared it that time)

Now to get to the point, I've always had one brake light light that doesn't work, it's a problem with how the bulbholder sits on the light. I tried fixing this the other day, pressing the brakes on and off to see when I had fixed it.

All was going well until suddenly the brake lights just cut out completly, and I had the BAS/ESP/ABS warning lights on the dash.

The BAS/ESP/ABS lights have never-ever come on while normally driving or anything.

I read on here that t may be the brake switch, I changed this, but they came on again when the brake was pished, and the steering left to right didn't clear them either!

Any thoughts? It has been fucntioning with just the one brake light for sometime now, could this have affected it?

Thanks all
 

·
Registered
02 ML55, 00 ML430 & 01 E430 4matic All Silver+Black
Joined
·
301 Posts
Have you tried to reset your car by removing the Battery lead for a minute or so and put back? Doing this you will have to resynchronize your windows, radio code, etc. How to do is in you user manual book.
You might also have a weak battery.
I hope you did not fry your computer module when you got it jumpstarted.
This is a fresh thread with similar issue.
LINK: http://www.benzworld.org/forums/w210-e-class/1378213-help-diagnost-bas-esp-abs-light.html
Good luck
 

·
Registered
2002 e320
Joined
·
344 Posts
If both brake lights are now not working, you should check the fuse.
For the brake light socket that is not holding the bulb, you might need to get a new tail-light assembly. There is also a diy in the diy section for troublshooting the faulty socket.
good luck
 

·
Registered
W211 E55 AMG
Joined
·
50 Posts
Discussion Starter #4
Have you tried to reset your car by removing the Battery lead for a minute or so and put back? Doing this you will have to resynchronize your windows, radio code, etc. How to do is in you user manual book.
You might also have a weak battery.
I hope you did not fry your computer module when you got it jumpstarted.
This is a fresh thread with similar issue.
LINK: http://www.benzworld.org/forums/w210-e-class/1378213-help-diagnost-bas-esp-abs-light.html
Good luck
Hi thanks for the reply.

The battery is newly replaced.

The jumpstart was months ago and the car has been fine eversince.

Will Disconnecting the clear the code do you think?
 

·
Registered
W211 E55 AMG
Joined
·
50 Posts
Discussion Starter #5
If both brake lights are now not working, you should check the fuse.
For the brake light socket that is not holding the bulb, you might need to get a new tail-light assembly. There is also a diy in the diy section for troublshooting the faulty socket.
good luck

Hi thanks of for the reply.

Where's the fuse for the brake lights, I had a look aroud the fuse box and under the seat but couldn't find it on the docs? Don't forget I also have the BAS ABS ESP errors up.

Thanks again
 

·
Registered
'01-E320 & 02-ST2
Joined
·
31,633 Posts
Hi, Sarah, did you change the brake switch or did you have it done? If you did it, can I ask where you bought the switch?

There are three fuse locations, one under the hood (which is where I think the ABS one is located, check the map there) as well as the one under the vertical panel at the left end of the dash (kind of a triangular door visible once you open the driver's door) and of course the one under the seat. My map was in the one under the hood.

Take care and enjoy the ride,
Greg
 

·
Registered
W211 E55 AMG
Joined
·
50 Posts
Discussion Starter #7
Hi, I changed it myself :)p) and I bought an original part from MB.

I've checked all the neccesary fuses and they're all fine, but I can't see wher any relays should be? Not on the map?

Thanks!
 

·
Registered
W211 E55 AMG
Joined
·
50 Posts
Discussion Starter #8
So guys, the brake lights don't work and the ABS BAS etc. lights are on the dash, I changed the brake switch, and the ABS BAS etc. lights are still on the dash, and the brake lights still don't work? :(
 

·
Registered
W211 E55 AMG
Joined
·
50 Posts
Discussion Starter #9
When people normally have the ABS BAS ESP light problem, do the brake lights work or not?

Thanks
 

·
Registered
02 ML55, 00 ML430 & 01 E430 4matic All Silver+Black
Joined
·
301 Posts
When I had this problem with my ex E320 the Brake Lights used to function properly.
 
1 - 10 of 10 Posts
Top