Mercedes-Benz Forum banner

1 - 11 of 11 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Hey last night at a red light i get this thing on the screen where the milage is...<br> <br> B A S<br> <br> then ASP<br> <br> then ABS<br> <br> now it says BAS ASP ABS Inopt!!<br> <br> So what causes that...and how do i fix.... I dont want to pay the dealer like 500.00 to fix a fuse or something like that.
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Reset it. Start the car....

turn the steering wheel fully counter clock wise then clock wise. Lights should turn off.<br> <br>
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Re: Reset it. um...... that did not work... more inside

OK i did what you said and it worked for abour 3 minutes then all the lights came back on.... so i tried it again and noting happend...<br> <br> Any other suggestions?
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #4
You definitely have a problem...

Mine was the MAS (Mass Airflow Sensor).<br> <br> Bring it to the dealer ASAP. I had that problem last year and waited until my next service visit. My car stalled in the middle of the highway and luckily was able to put the car on the side.<br>
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Re: You definitely have a problem...

Grand.... it was just there last week for a rack and pinion and power steering pump... Also the traction controll does not work now... found that out in the rain today...
 

·
Registered
Joined
·
2 Posts
i have a 2003 clk 320 my battery light came on. also my coolant light came on after that. Also my steering wheel was hard to turn i can turn it but is hard. i don't know if its my battery if I need coolant and power steering fluid. please help
 

·
Outstanding Contributor , SDS Guru
1998 MB E300TD, 1997 MB E36 AMG, 2001 MB E55 AMG
Joined
·
5,493 Posts
i have a 2003 clk 320 my battery light came on. also my coolant light came on after that. Also my steering wheel was hard to turn i can turn it but is hard. i don't know if its my battery if I need coolant and power steering fluid. please help
That sounds like the belt snapped.... and then you have no alternator, power steering, water pump.

First thing you should do: tow the car. Do not drive it, unless you're an accomplished DIY and can replace the belt yourself.
 

·
Registered
2001 CLK320 Cabrio
Joined
·
397 Posts
farrahpleasants2015.........do as Deplore said.

If you need to replace the serpentine, a new one is only about $30 and a very quick and easy repair. Especially on your CLK 320 engine, where there plenty of room to work. The labor is just releasing the tension on the belt tensioner and slipping on the new belt.

I would strongly suggest checking the idler pulley (a.k.a. guide pulley). It's a small plastic pulley with a single bearing and very commonly fails (e.g. pulley cracks and disintegrates or the bearing seizes, causing belt failure and breakdown).

When I changed mine, as preventive maintenance, at 85,000 miles, I found 3 cracks.

A new pulley was only $12 and only takes another minute or so to replace while the belt tension is released (e.g. attaches to the engine with a single bolt).
 

·
Registered
R230 SL350 Presnt, Past - W208 CLK230K 2000, W203 C Class, W202 C Class, W210 E Class, W201 190E
Joined
·
1,479 Posts
have you changed your brake switch as a faulty one can turn on these lights.
 

·
Registered
2003 CLK320 Cabriolet
Joined
·
142 Posts
Yep, brake switch worth a good look.

I had identical symptoms and found the brake switch suggestion in several places on this forum. Cost me $12 from the dealer and was a surprisingly easy DIY.

Problem solved!
 

·
Registered
2001 CLK320 Cabrio
Joined
·
397 Posts
Caution.......this thread has two different issues and solutions being discussed.

Initially, Shawn posted a BAS/ABS dash light error, after which farrahpleasants2015 added an issue with a battery light warning.

While the BAS/ABS warning can be due various reasons (e.g. faulty break light switch, wheel speed sensor etc.), the original switch was such a common problem that MB redesigned the switch. The new part number is 001-545-64-09 and cost $20 from the dealer.

FWIW, whenever I encountered an occasional BAS/ABS warning while braking, the warning always reset itself by just restarting the car.
 
1 - 11 of 11 Posts
Top