Mercedes-Benz Forum banner
1 - 6 of 6 Posts

·
Registered
1990 190D 2,5 turbo
Joined
·
7 Posts
Discussion Starter · #1 ·
hey,

i have had some problems with my wiper lately, and today i was in a big city in norway for the first time in the dark and hevy rain, and then the wiper stopped.
the wiper moves really slowly over the window and there is no difference between step 2 and 3.on the trip I senced a bad smell in the car that I think come from the wipermotor. i found out that the fuse was blown, so when i changed it, it exploded when i took the wiper to step 3.
I'm wondering if the mechanism is slow and the motor has been blown so i have to change the hole part?

1986 190D 2,0
 

·
IR MODERATOR
1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Joined
·
9,228 Posts
yep, it sounds like a bad motor.
 

·
IR MODERATOR
1996 Volvo 855GLT, 1993 MB 190e 2.3 8v, 1998 Subaru Outback SUS, 1991 BMW 525, 1998 MB C230
Joined
·
9,228 Posts
theres either a short in the wiring or the motors bad, in either case you need to take the wiper assembly out.
 

·
Registered
1990 190D 2,5 turbo
Joined
·
7 Posts
Discussion Starter · #5 ·
okey, but i think the mechanisme is bad aswell so i think i change that too. found a used one but he's asking 135 dollars for it...
 

·
Registered
1984, 201.122, OM601.921, G717.410
Joined
·
504 Posts
Perhaps something external caused the motor to fail. After disconnecting the wiper linkage from the motor, examine how freely it moves. Substantial friction or resistance will impart an excessive load on the motor. Too much being loose may also be a problem. Some parts of the linkage may require lubrication, or bushings may need to be replaced.
 
1 - 6 of 6 Posts
Top