Mercedes-Benz Forum banner

1 - 5 of 5 Posts

·
Registered
2001 ML 320
Joined
·
40 Posts
Discussion Starter #1
I found out that one of the seat struts is broken, found couple marbles that my kids have in the area, could be that when the seat is lowered the marbles caused the strut to broke in half. The struct is used to help slowly lower the back seats.

I am having diffulty install the replacement as the struct is longer that the two studs on each end. Do I need to compress the strut? I tried adjusting the seats but no success.

Attached is a picture of the good and broken strut and also where the strut is attached to on the seat.

thanks.


 

·
Registered
ML320/C320 Sprt
Joined
·
4,649 Posts
its aesy to replace, first take the broken one out by removing the "C" type clip holding the broken piece. You can use the small screw driver to pry it out then, from the new one remove the clip first then sit the both end in place then simply push the "C" clip to secure the head. hope this help.
 

·
Registered
2001 ML 320
Joined
·
40 Posts
Discussion Starter #3
Hi Jim, taken it out is no problem. The problem is the length between the two studs is shorter than the strut and somehow I need to compress the strut to make it clip into place.

To confirm this I also taken it the good strut on the otherside and once I unclipped and pops out the strut it extends out a little and no longer fits.
 

·
Registered
ML320/C320 Sprt
Joined
·
4,649 Posts
Hmmmnnn, I don't know if you already do this technique , how about try to secure one end then pushing the strut in and at the same time when its level/align to the stud push it in. It's works for me all the time, while changing the Gas Shocks, Gas shocks was much stronger than that I assumed.
 

·
Registered
2001 ML 320
Joined
·
40 Posts
Discussion Starter #5
I already tried that and it doesn't move at all, it is VERY hard. I tried different pilers and still no go. I even hammered it and it still won't go in. ahhh!!!!

So far I already spent 3 hours trying different tools and still couldn't figure it out. They must have some special tool at the factory to install this thing.
 
1 - 5 of 5 Posts
Top