Mercedes-Benz Forum banner

1 - 10 of 10 Posts

·
Registered
W245 B150 CVT
Joined
·
13 Posts
Discussion Starter #1
Hi all Im new here with my B 150 2006 CVT .

My problem is that the car seem to accelerate very slow even the full throttle pressed down.
Aswell there seems o be small issue with CVT but not major.

First the engine got a new timing chain fitted with sprocket and manifold absolute pressure sensor.
That was done with full service oils etc including cvt oil filter gasket.
The engine reving very slowly like there is a some air blockage.
I checked the Catalicconverter with special MB tool and it is ok.
Fault codes from star diagnosis shows no faults.
Got replaced a throttle valve and got it adapted trough star diagnostic.
Got a new software update for engine aswell.
But still slow reving and acceleration but it does the speed it can reach 140km/h it accelerate but like snail.
I compare that with other B150 2007 and 2006 year and they are better in acceleration.

Question can that be a bad Timing ??? Does not that show in Star diagnostic

The CVT gearbox is nice and smooth as I never drive smoother gearbox.
But time to time it does not shift to 7th gear and that time it seem to be between 5-6 as the revs are 2300rpm in 100km/h
if its normal in the 7th gear 100km/h revs are 1900rpm
I need to turn off ignition and on that the gearbox will work in 7th gear again.
This are happening time to time but found it when I rev it up as i want to overtake then it make this fault.

I got all codes sorted and the car does not show any faults.


Please any helps.
 

·
Registered
w245 2006
Joined
·
258 Posts
Hi all Im new here with my B 150 2006 CVT .

My problem is that the car seem to accelerate very slow even the full throttle pressed down.
Aswell there seems o be small issue with CVT but not major.

First the engine got a new timing chain fitted with sprocket and manifold absolute pressure sensor.
That was done with full service oils etc including cvt oil filter gasket.
The engine reving very slowly like there is a some air blockage.
I checked the Catalicconverter with special MB tool and it is ok.
Fault codes from star diagnosis shows no faults.
Got replaced a throttle valve and got it adapted trough star diagnostic.
Got a new software update for engine aswell.
But still slow reving and acceleration but it does the speed it can reach 140km/h it accelerate but like snail.
I compare that with other B150 2007 and 2006 year and they are better in acceleration.

Question can that be a bad Timing ??? Does not that show in Star diagnostic

The CVT gearbox is nice and smooth as I never drive smoother gearbox.
But time to time it does not shift to 7th gear and that time it seem to be between 5-6 as the revs are 2300rpm in 100km/h
if its normal in the 7th gear 100km/h revs are 1900rpm
I need to turn off ignition and on that the gearbox will work in 7th gear again.
This are happening time to time but found it when I rev it up as i want to overtake then it make this fault.

I got all codes sorted and the car does not show any faults.


Please any helps.
Did you press sport mode before accelerating? My car also accelerates very slowly even if I full press throttle. I've been thinking this is the car's acceleration characteristic. Sometimes if I release and then re-press the throttle it starts to accelerate. I never thought this is a problem. Should I worry?

Mi-4c cihazımdan Tapatalk kullanılarak gönderildi
 

·
Registered
W245 B150 CVT
Joined
·
13 Posts
Discussion Starter #3
yes I try that in a S mode but from standstill its like slug without power even full throttle pressed kicked down.

My problem is moving from junction or rd-bound.
 

·
Registered
W123 '83 200, W210 '98 E200K, W212 '13 E350
Joined
·
1,814 Posts
Are you guys sure your transmission is downshifting?

What about in manual mode (-D+), using the lever to downshift when stopped?

Does the acceleration improve?
 

·
Registered
W245 B150 CVT
Joined
·
13 Posts
Discussion Starter #5
I try that and NO still same.
I will Upload video tomorrow showing acceleration on my 2006,
and other one that I try even without engaging gear (on neutral)
The reving is slow to get to 4500rpm compare to other B150 automatic.
She goes to 4500rpm in about 2s my one takes 3-4 seconds.
 

·
Registered
W245 B150 CVT
Joined
·
13 Posts
Discussion Starter #7
Well sound like that to me but how do I check it. Shoud the Star Diagnistic tell me that.
 

·
Registered
W245 B150 CVT
Joined
·
13 Posts
Discussion Starter #8
SORTED problem was as follow the thermostat was wrng and did not get to the 75dergee temperature for gearbox then the gearbox keep higher revs to heat up as well due to bad thermostat there was mess bilded up on oil pressure sensor witch was givving wrong values to ecu after thermostat and pressure swtch replacement car is OK
 

·
Registered
2006 B 200 .....& Audi A6..
Joined
·
8,160 Posts
Glad to hear that all is now OK..and thanks for the added info on this problem..
 

·
Registered
B170 W245 CVT
Joined
·
1 Posts
SORTED problem was as follow the thermostat was wrng and did not get to the 75dergee temperature for gearbox then the gearbox keep higher revs to heat up as well due to bad thermostat there was mess bilded up on oil pressure sensor witch was givving wrong values to ecu after thermostat and pressure swtch replacement car is OK
Hi, I’m Martijn from the Netherlands.
I have exactly the same problem with my B170 CVT. The engine seems OK.
The CVT sometimes does not go to ‘7th’ gear. After switching contact it works OK again.
Could you give me some more info about which thermostat and oil press. switch was replaced on your car? I have a hard time finding schematics on this gearbox electronics.
You seem to be the only one on the world wide web who had the same problem as I had.
any help is appreciated!

Best regards,
Martijn van Geenen
 
1 - 10 of 10 Posts
Top