Mercedes-Benz Forum banner
21 - 36 of 36 Posts

·
Registered
B250 2013 Sport Jupiter Red, Honda 2018 CR-V Touring, Dark Blue
Joined
·
148 Posts
The coolant thermostat in the motor, my local indy MB mechanic did the job, not cheap
 

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
77 Posts
i see, thanks for the info.
why was it replaced? was there an error code?

I assume that has an electronic component that provide temp readings to ECM (or maybe im confusing thermostat and coolant temp sensor)
I will try and see if I can read this values from my scanner and see what is the reading when ECO is on and when ECO is off - im not yet sure if this is possible.

cheers
 

Attachments

·
Registered
B250 2013 Sport Jupiter Red, Honda 2018 CR-V Touring, Dark Blue
Joined
·
148 Posts
I was getting a P0128 code, which kept coming back after clearing
 

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
77 Posts
I was getting a P0128 code, which kept coming back after clearing
so i've the scanned every module in the car and no current faults or anything possible related to this. There was 1 historic fault on radar, I cleared that too.

quick update: eco-start stop is ALIVE again (green!) for this B-klasse, engages almost all the time when speed of 20km/h is reached

here are the sequence of events leading to it (hoping it might help anyone out there ):

1. recharged main battery overnight (batt is 1mo old), used noco smart charger with AGM mode, cleared all codes, - went for a 10min drive, no green light on dash

2. replaced 1.2Ah aux battery from new generic to old mb (previous one), also while at it I also pressed down all fuses and relay located below this aux batt - went for a 10min drive, still no green light on dash

3. left car for about 4 hours, went for a drive again and green light stayed on for my whole 45 min drive....now I have to disable it again manually! :) same results next morning, noticed on some occasions it never turned green after starting, so when stopped at lights, I manually switch engine off (push button), then switch on - green light is back! maybe I need a software update too.

anyway, not sure if changing the aux batt did it, the overnight charging of main batt or it was just taking time to learn the battery charge levels and eventually worked

ps. I do think that little aux batt is just a backup for something critical like transmission (so it can be shifted to N) and may have nothing to do with eco start stop? anyone knowledgeable on this?
 

·
Registered
Joined
·
11 Posts
Hello, I have had to jump start my B200 (Petrol) for the second time in two months. The next day it starts just fine.

If I need/want to put in a new battery, is it the start/stop battery in the engine bay or the one under the footwell I should replace?

I NEVER use the start/stop function. I always disable it right after I start the car.

Thanks in advance.

Sixcarbs
 

·
Registered
B250 2013 Sport Jupiter Red, Honda 2018 CR-V Touring, Dark Blue
Joined
·
148 Posts
What year is your car?
Mine is 2013 and I have had to replace only the footwell battery.
Any chance you could go and get a scan to help determine if any codes, might help narrow down which one is causing the problem?
 

·
Registered
Joined
·
11 Posts
What year is your car?
Mine is 2013 and I have had to replace only the footwell battery.
Any chance you could go and get a scan to help determine if any codes, might help narrow down which one is causing the problem?
Mine is a 2013.

Is the footwell battery the main battery?
 

·
Registered
W163 W202 W203 W246 MB100D
Joined
·
77 Posts
Hello, I have had to jump start my B200 (Petrol) for the second time in two months. The next day it starts just fine.

If I need/want to put in a new battery, is it the start/stop battery in the engine bay or the one under the footwell I should replace?

I NEVER use the start/stop function. I always disable it right after I start the car.

Thanks in advance.

Sixcarbs
how old is the battery?

if its too old or needs to be to be replaced, its the one on the engine bay.

batt under the footwell is too small to be the starting battery.
 

·
Registered
Joined
·
1 Posts
hello. i've got problem with auxiliary battery in my w246. There is empty pocket where should be the battery. Green light is stayed on but start/stop doesnt work. How to insert the battery and conect it? pls help
 

·
Registered
B250 2013 Sport Jupiter Red, Honda 2018 CR-V Touring, Dark Blue
Joined
·
148 Posts
Is the empty pocket in the passenger footwell?
There are some YouTube videos on how to install, might help
 
21 - 36 of 36 Posts
Top