Mercedes-Benz Forum banner

1 - 6 of 6 Posts

·
Premium Member
2007 SL55 AMG P030 -2007 S65 AMG
Joined
·
265 Posts
Discussion Starter #1
I have been working to reolve an overnight ghost battery drain on a 2007 SL550

The attached pictures show the method I used to find out were the drain was coming from ( In this case the rear SAM) The same method can be applied to the front SAM units.

I'm just sharing, perhaps this may help some others that have the same problem.

Best H
2617470
2617471
 

·
Registered
2005 SL65 plus 13 other non MB toys
Joined
·
764 Posts
Love it! The common sense approach methodically executed. I have used that method for years. Bravo!!
 

·
Registered
Joined
·
2 Posts
I have been working to reolve an overnight ghost battery drain on a 2007 SL550

The attached pictures show the method I used to find out were the drain was coming from ( In this case the rear SAM) The same method can be applied to the front SAM units.

I'm just sharing, perhaps this may help some others that have the same problem.

Best H View attachment 2617470 View attachment 2617471
Great work!

I also have a 2.5 amp drain on the service battery so will check thi sfault first

Where did you source a replacement (new?) fuse block please?

Thanks
 

·
Premium Member
2007 SL55 AMG P030 -2007 S65 AMG
Joined
·
265 Posts
Discussion Starter #4
Great work!

I also have a 2.5 amp drain on the service battery so will check thi sfault first

Where did you source a replacement (new?) fuse block please?

Thanks
You'll find plenty of these on eBay complete fuse block attached to the Sam (silver color item in the picture) The SAM can be removed/ slide away from the fues block with 2 screw drivers as you can be see on the attached label on the SAM part.

The fault is more than likely inside the circuit board that's located inside the SAM and you can re-use your own fuse block.

Best H
2620701
 

·
Registered
Joined
·
2 Posts
That's excellent thanks.

I guess its pot luck that the one from ebay doesn't show the same problem?

Thanks for your help
 

·
Premium Member
2007 SL55 AMG P030 -2007 S65 AMG
Joined
·
265 Posts
Discussion Starter #6
That's excellent thanks.

I guess its pot luck that the one from ebay doesn't show the same problem?

Thanks for your help
If you first disconnect the main power cable to your rear fuse block and see on the your Amp meter that the current draw stops you know that it's the SAM that is bad.
The ones on eBay don't offer quarantees that they are good however look for one that show the least amount of abuse in the pictures and use a supplier with the least amount of negative feed back.

Best H
 
1 - 6 of 6 Posts
Top