Mercedes-Benz Forum banner

1 - 18 of 18 Posts

·
Registered
2010 Mercedes Benz C300 4matic Sport
Joined
·
52 Posts
Discussion Starter #1
I have my automatic headlights going on during the daytime. It not only turns on but then turns off a little while later and then back on. I have gotten in the habit of just turning it off because I do not want other drivers thinking that I am flashing them. Where is the light sensor located? Anyone come across a similar situation or solution?

Sent from my Galaxy Nexus using AutoGuide.Com Free App
 

·
Registered
2008 C300 Barolo Red P2 MM leather 18" AMGs new style folding mirrors + 1984 944
Joined
·
327 Posts
I have my automatic headlights going on during the daytime. It not only turns on but then turns off a little while later and then back on. I have gotten in the habit of just turning it off because I do not want other drivers thinking that I am flashing them. Where is the light sensor located? Anyone come across a similar situation or solution?
The rain and light sensors are at the top of the windshield. Are your headlights set on automatic at the switch or do you have them set as DRLs in the dash menu? Or both?
 

·
Registered
2010 Mercedes Benz C300 4matic Sport
Joined
·
52 Posts
Discussion Starter #4
I did bring it to the dealer once already. I will be bringing it back. They said that they took the whole thing apart but found nothing wrong. It worked for a while and then the problem came back. I do not have daytime running lights on. I am talking about the automatic lights setting on the headlights turn knob.

Sent from my Galaxy Nexus using AutoGuide.Com Free App
 

·
Registered
2008 C300 Sport
Joined
·
110 Posts
It seems they are doing their job. Of course, if you choose not to manually turn them on and off, this is a problem you'll have to live with because the sensor can be fooled.
 

·
Registered
2008 C300 Lux Black on Black
Joined
·
68 Posts
Anyone come across a similar situation or solution?
May be unrelated. But I'm about to have my headlight switch checked again. For awhile my headlights would turn on and off while driving at night. They reprogrammed the unit and that problem went away. But now the passenger side parking lights are randomly on in the middle of the night with the switch in the off position. Last visit the service dept tried to tell me i was not turning the switch to the full detent position, but that's not true.
 

·
Registered
Joined
·
5 Posts
May be unrelated. But I'm about to have my headlight switch checked again. For awhile my headlights would turn on and off while driving at night. They reprogrammed the unit and that problem went away. But now the passenger side parking lights are randomly on in the middle of the night with the switch in the off position. Last visit the service dept tried to tell me i was not turning the switch to the full detent position, but that's not true.
Andy, have they resolved the passenger side parking light issue, what did they do? My car has those symptoms.

Thanks,
 

·
Registered
2008 C300 Lux Black on Black
Joined
·
68 Posts
Andy, have they resolved the passenger side parking light issue, what did they do? My car has those symptoms.
They finally replaced the headlight switch last week after I complained over and over again. My battery was also replaced as it did not pass a test either. I won't know for sure if the problem is solved unless it happens again. Let us know how you come out.
 

·
Registered
2009 C300 Sport 4matic
Joined
·
116 Posts
I just posted a thread a second ago. Mine do THE EXACT SAME THING!!!!! My switch in the auto position triggers my lights to go on and off when the car is just sitting there. When I drive at night, my headlights will randomly blink off/on. Constant problems with my side markers shorting out too! Did the new switch help?
 

·
Registered
'10 E350 coupe; SOLD--'10 C300; SOLD--'10 ML
Joined
·
251 Posts
The headlights would go off randomly at night. Finally resolved after they found a problem in the switch.

I have heard many others on here complain about this same issue. Dealers should be up to speed on this by now.
 

·
Registered
Joined
·
5 Posts
They finally replaced the headlight switch last week after I complained over and over again. My battery was also replaced as it did not pass a test either. I won't know for sure if the problem is solved unless it happens again. Let us know how you come out.
Andy,

Dome time has passed since I last asked you. I am curious, has your problem gone away since they replaced the switch?

Thanks,
Huy
 

·
Registered
2010 Mercedes Benz C300 4matic Sport
Joined
·
52 Posts
Discussion Starter #14
I am going to pay a visit to the dealership this week. I recorded a video showing them turning on and off in the daylight while sitting still. I will also mention that passenger side parking light issue. Because mine also does the same. Neighbors always warn me that my lights are on. I will report back what happens.
 

·
Registered
Joined
·
53 Posts
Here is the tsb information:

NHTSA Item Number: 10033072
Service Bulletin #: LI-54-21
Replacement #:
Vehicle/Equipment Make: MERCEDES BENZ
Vehicle/Eqipment Model: C300
Model Year: 2010
Mfg Component Code: 122000 EXTERIOR LIGHTING:FOG LIGHTS
Date of Bulletin: 2009-12-17
Date Added: 2010-06-30
Summary: XENTRY: EXTERIOR LIGHTS CONSTANTLY ON. POSSIBLE COMPONENTS: LOW BEAMS; FRONT FOG LAMP; HIGH BEAMS; WASHER FLUID PUMP AND THE HEADLAMP CLEANING SYSTEM ARE ALSO POTENTIALLY AFFECTED. HARDWARE FAULT IN DRIVER SIDE SAM. MODEL 204. NO MODEL
 

·
Registered
2008 C300 Lux Black on Black
Joined
·
68 Posts
Sounds like you have a SAM problem. There is a tsb on this issue.
Just a note from my experience with both the headlights randomly turning on and off while driving at night and the passenger side marker (parking) lights randomly on at night when engine and headlight switch off: Service reprogrammed SAM and 6 months later the switch was replaced.
 

·
Registered
2010 Mercedes Benz C300 4matic Sport
Joined
·
52 Posts
Discussion Starter #18
I just had mine looked at by the dealership. They are replacing the headlight switch. It took them three days to diagnose the problem.

Sent from my Nexus 7
 
1 - 18 of 18 Posts
Top